HDU1092 A+B for Input-Output Practice (IV)

  • Problem Description
    Your task is to Calculate the sum of some integers

  • Input
    Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.

  • Output
    For each group of input integers you should output their sum in one line, and with one line of output for each line in input.

  • Sample Input
    4 1 2 3 4
    5 1 2 3 4 5
    0

  • Sample Output
    10
    15

  • Author
    lcy

  • 代码

#include<iostream>
using namespace std;
int sum(int n,int *N){
    int s=0;
    for(int i=0;i<n;i++) s+=N[i];
    return s;
}
int main(){
    int n,N[1000];
    int a,b;
    while(~scanf("%d",&n)){
        if(n==0) break;
        for(int i=0;i<n;i++) cin>>N[i];
        long long sum_;
        sum_=sum(n,N);
        printf("%d\n",sum_);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值