Tempter of the Bone (dfs)

     The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

    The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
Input
    The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

    'X': a block of wall, which the doggie cannot enter;
    'S': the start point of the doggie;
    'D': the Door; or
    '.': an empty block.

    The input is terminated with three 0's. This test case is not to be processed.
Output
    For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
Sample Input

    4 4 5
    S.X.
    ..X.
    ..XD
    ....
    3 4 5
    S.X.
    ..X.
    ...D
    0 0 0

Sample Output

    NO
    YES

题意:一个n*m的矩阵,老鼠的起点在矩阵中的'S'上,终点在矩阵中的'D',其中'X'是墙,老鼠不能通过, '.'是路但是只能通过一次,过了一次之后就不能再走这个地方了,终点D在第K秒是打开,这就要求老鼠能够在第K秒是正好到达D点,如果不能就输出NO,可以的话就输出YES.

分析:这个题做的话需要剪枝,如果不剪枝就会超时。这里的剪枝,可以通过起点与终点的最短距离与要求的时间K同奇偶的特性来进行判断。同奇偶性是指起点与终点是确定的,所以在不考虑中间有没有墙的情况下有一个最短的距离,这个距离的奇偶性如果与要求的K的奇偶性不相同的话,那他绝对不可能到达。

#include<stdio.h>
#include<string.h>
#include<math.h>

int ex,ey,m,n,t,flag,book[10][10];
char a[10][10];
void dfs(int sx, int sy, int step)
{
	int i,dx,dy;
	int next[4][2] = {0,1,1,0,0,-1,-1,0};
	if(flag)
		return ;
	if(sx == ex && sy == ey && t == step)
	{
		flag = 1;
		return ;
	}
	int tem = t - step - abs(ex-sx) - abs(ey-sy);
	if(tem < 0 || tem & 1)
		return ;
	for(i = 0; i < 4; i ++)
	{
		dx = sx + next[i][0];
		dy = sy + next[i][1];
		if(dx < 0 || dx >= n || dy < 0 || dy >= m)
			continue;
		if(a[dx][dy] != 'X' && book[dx][dy] == 0)
		{
			book[dx][dy] = 1;
			dfs(dx,dy,step+1);
			book[dx][dy] = 0;
		}
	}
	return ;
}
int main()
{
	int i,j,sx,sy,count;
	while(scanf("%d%d%d",&n,&m,&t), n!= 0 || m!= 0 || t != 0)
	{
		flag = 0; count = 0;
		memset(book,0,sizeof(book));
		for(i = 0; i < n; i ++)
			scanf("%s",a[i]);
		for(i = 0; i < n; i ++)
		{
			for(j = 0; j < m; j ++)
			{
				if(a[i][j] == 'S')
				{
					sx = i;sy = j;
				}
				if(a[i][j] == 'D')
				{
					ex = i;ey = j;
				}
				if(a[i][j] == 'X')
					count ++;
			}
		}	
		if(t > m*n-count-1)
		{
			printf("NO\n");
			continue;
		}
		
		book[sx][sy] = 1;
		dfs(sx,sy,0);
		if(flag == 1)
			printf("YES\n");
		else
			printf("NO\n");
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值