结构体--大小排列

问题描述:给定数量和面值的金钱,以及需要支付的金额,不用考虑需要支付金钱的数量,输入输出案例如下:

Sample Input
735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10
Sample Output
735
630
0
0

假设我们用贪心算法,从最大面值开始统计(这种思路不合理)

#include<algorithm> 
#include<cmath>
#include<cstring>
#include<queue>
#include<iostream>
using namespace std;
struct node{
	int num,me;
	bool operator <(const node &a)const{
        return me<a.me;
    }
}s[10010];
int main(){
	int sum,n;
	while(scanf("%d%d",&sum,&n)!=EOF){
		int SUM=sum;
		for(int i=0;i<n;i++)
			cin>>s[i].num>>s[i].me;//对应数量和面额值
		sort(s,s+n);
		//for(int i=0;i<n;i++)
		//	cout<<s[i].num<<" "<<s[i].me<<endl;
		int t=0;
		for(int i=n-1;i>=0;i--){
			t=min(sum/s[i].me,s[i].num);
			sum-=t*s[i].me;
            //ans+=t;//ans用于计数的
		}
		cout<<SUM-sum<<endl;//可以满足的情况
        //cout<<ans<<endl;输出可以的最小金钱的数量
	}
	
}
/*Sample Input
735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10
Sample Output
735
630
0
0*/

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值