NEUQ-ACM第一次双周赛

7-1 Lily

分数 300

全屏浏览题目

切换布局

作者 neuqAcmClub

单位 东北大学秦皇岛分校

百合花(Lily)是一种美丽的花。她通常一年只开一次花,所以如果你看到百合花盛开,它会非常珍贵。然而,她对猫有剧毒,所以你必须注意让好奇的猫远离可爱的百合花。

你有n个网格的土壤土地排成一行,从1到n,其中一些是百合花。我们不想伤害百合,也不想伤害猫。你可以在网格上放一些猫粮,但对于任何有猫粮的网格i,在区域[i−1,i+1]不得含有百合花。你喜欢猫和百合,所以你想最大限度地增加有猫粮的格子。

设计满足上述要求的计划。

输入格式:

有一个整数n(1≤n≤1000)表示网格的数量。

第二行包含仅由“L”和“.”组成的字符串R,表示有和没有百合花的格子。

输出格式:

输出包含一行,字符串R′仅由“L”、“”组成和“C”,其中“C”表示在满足上述要求的同时分配给R中空网格的猫粮。

输入样例:

在这里给出一组输入。例如:

5
..L..

输出样例:

在这里给出相应的输出。例如:

C.L.C

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

#include<iostream>
#include<string>
using namespace std;
string a,b;
int len;
int main()
{
    cin>>a;
	cin>>a;
	b=a;
	len=a.size();
	if(a[0]=='.'&&a[1]=='.')
	{
		b[0]='C';
	}
	for(int i=1;i<len;i++)
	{
		if(a[i]=='.'&&a[i-1]!='L'&&a[i+1]!='L')
		{
			b[i]='C';
		}
	}
	cout<<b;
	return 0;
}

7-2 a * b

分数 300

全屏浏览题目

切换布局

作者 neuqAcmClub

单位 东北大学秦皇岛分校

给出两个不超过1000位的十六进制数a,b。
求a∗b的值

输入格式:

输入共两行,两个十六进制的数

输出格式:

输出一行,表示a∗b

输入样例:

在这里给出一组输入。例如:

1BF52
1D4B42

输出样例:

在这里给出相应的输出。例如:

332FCA5924

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

#include<iostream>
#include<string>
#include<cstring> 
using namespace std;
int num(char n)
{
	if(n>='0'&&n<='9')
	{
		return ((int)n-(int)'0');
	}
	else
	{
		return (10+(int)n-(int)'A');
	}
}
char ch(int a)
{
	if(a>=0&&a<=9)
	{
		return (char)(a+(int)'0');
	}
	else
	{
		return (char)(a-10+(int)'A');
	}
}
string a,b,c;
int la,lb,t,carry,m,carry1;
int main()
{
	cin>>a;
	cin>>b;
	c="0";
	la=a.size();
	lb=b.size();
	for(int i=1;i<la+lb-1;i++)
	{
		c=c+'0';
	}
	for(int i=la-1;i>=0;i--)
	{
		carry=0;
		for(int j=lb-1;j>=0;j--)
		{
			if(!j)
			{
				m=carry1;
				carry1=0;
			}
			t=num(a[i])*num(b[j])+carry+num(c[i+j])+m;
			carry=t/16;
			t-=16*carry;
			c[i+j]=ch(t);
		}
		m=0; 
		t=carry+num(c[i-1]);
		carry1=t/16;
		t-=16*carry1;
		if(i)
		{
			c[i-1]=ch(t);
		}
	}
	t=t+7;
	if(t!=0)
	{
		c=ch(t)+c;
	}
	
	cout<<c<<endl;
	return 0;
}

 

7-3 山头狙击战

分数 300

全屏浏览题目

切换布局

作者 neuqAcmClub

单位 东北大学秦皇岛分校

题目描述

小明为了掩护大部队,单枪匹马同敌人周旋,后来被敌人包围在某山头……等等,为什么怎么听怎么像狼牙山五壮士!不过不用着急,这次小明携带了足够的弹药,完全可以将涌上来的敌人一个一个干掉。小明是个神枪手,只要他的枪膛中有子弹,他就能将在他射程m(用从敌人位置到山头的直线距离算)以内的一个敌人瞬间射杀。但如果在射程内没有敌人,出于节约子弹考虑和面子问题,小明会等待敌人靠近然后射击。
正当小明为自己的强大而自我膨胀时,他忽然发现了一个致命的失误:他携带的枪是单发枪,每射出一发子弹都必须花k秒钟的时间装子弹。而凶残的敌人才不会花时间等你换子弹呢。他们始终在以1m/s的速度接近山头。而如果在一个敌人到达山头时小明无法将他击毙,那么我们可怜的小明就将牺牲在敌人的刺刀下。现在小明用心灵感应向你发出求助:要保住自己的性命并且歼灭所有敌人,小明最多只能用多少时间给枪装上一发子弹?
说明:假设一开始小明的枪中就有一发子弹,并且一旦确定一个装弹时间,小明始终会用这个时间完成子弹的装卸。希望你能帮助小明脱离险境。

输入格式

每组输入数据,第一行有两个整数n和m,(2≤n≤100,000; 1≤m≤10,000,000)n代表敌人个数,m代表小明的射程。
接下来有n行,每行一个整数mi,(1≤mi≤10,000,000),代表每个敌人一开始相对山头的距离(单位为米)。

输出格式

每组输出数据仅有一个整数,代表小明的换弹时间(单位为秒)。

样例输入

6 100
236
120
120
120
120
120

样例输出

25

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

#include<bits/stdc++.h>
using namespace std; 
int l=0,r=1e8+5,mid,m,n,d[200005],ans=-1;
bool check(int t)
{
	int i=0,time=0;
	while(i<n)
	{
		if(d[i]<time)
		{
			return 0;
		}
		if(d[i]>m+time)
		{
			time+=d[i]-m-time;
		}
		i++;
		time+=t;
	}
	return 1;
}
int main()
{
	cin>>n>>m;
	for(int i=0;i<n;i++)
	{
		cin>>d[i];
	}
	sort(d,d+n);
	while(l<=r)
	{
		mid=(l+r)/2;
		if(check(mid))l=mid+1,ans=mid;
		else r=mid-1;
	}
	cout<<ans;
}

 

7-4 Reversing Linked List

分数 300

全屏浏览题目

切换布局

作者 陈越

单位 浙江大学

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤105) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

#include<bits/stdc++.h>
using namespace std;
string st(int x)
{
	string s="00000";
	int t=10000,i=0;
	if(x==0)
	{
		return s;
	}
	else
	{
		while(t>=1)
		{
			s[i]=x/t+'0';
			x=x%t;
			t/=10;
			i++;
		}
	}
	return s;
}
const int sta=100000;
struct staa
{
	int r,a;
	int v;
}L[sta+5];
struct adad
{
	string a,r;
	int v;
}aa[sta+5]={"0","-1"};
int N=0,fa,ii=0;
int n,k,la=sta,flat=1;
int main()
{
	cin>>fa>>n>>k;
	L[sta].r=fa;
	for(int i=1;i<=n;i++)
	{
		int ta;
		cin>>ta;
		cin>>L[ta].v>>L[ta].r;
	}
	for(int u=L[sta].r;u+1;u=L[u].r)
	{
		aa[ii].a=st(u);
		aa[ii].r=st(L[u].r);
		aa[ii].v=L[u].v;
		if(L[u].r==-1)
		{
			aa[ii].r="-1";
		}
		ii++;
	}
	for(int j=0;j<ii;j++)
	{
		N++;
		if(N==k)
		{
			for(int b=0;b<N;b++)
			{
				int m=j-b;
				if(flat==1)
				{
					cout<<aa[m].a<<" ";
					flat=0;
				}
				else
				{
					cout<<" "<<aa[m].a<<"\n"<<aa[m].a<<" ";
				}
				cout<<aa[m].v;
			}
			N=0;
		}
	}
	for(int m=ii-N;m<ii;m++)
	{
		if(flat==1)
		{
			cout<<aa[m].a<<" ";
			flat=0;
		}
		else
		{
			cout<<" "<<aa[m].a<<"\n"<<aa[m].a<<" ";
		}
		cout<<aa[m].v;
	}
	cout<<" -1\n";
	return 0;
}

 

7-5 一元三次方程

分数 300

全屏浏览题目

切换布局

作者 neuqAcmClub

单位 东北大学秦皇岛分校

给定一个形如ax3+bx2+cx+d=0的一元三次方程。

已知该方程有三个不同的实数根(根与根之差的绝对值≥10−6),且根范围均在[p,q]之间,你需要解出这个方程的三个根。

输入格式:

第一行一个整数T(1≤T≤1000),表示有T组数据

接下来T行,每行6个实数,分别表示a,b,c,d,p,q

数据保证:−102≤p,q≤102,且对于∀x∈[p,q],−106≤f(x)≤106

输出格式:

输出三个实数,表示方程的三个解。

你的答案可以以任意顺序输出。

一个答案被认为是正确的,当且仅当其与标准答案的绝对误差不超过10−6

输入样例:

在这里给出一组输入。例如:

1
1.000000 -5.000000 -4.000000 20.000000 -10.000000 10.000000

输出样例:

在这里给出相应的输出。例如:

-2.000000 2.000000 5.000000

提示1:

样例所给方程的图像如下:

提示2:

对于方程:ax2+bx+c=0(Δ=b2−4ac≥0),它的两个根分别为:x1​=2a−b−Δ​​,x2​=2a−b+Δ​​

代码长度限制

16 KB

时间限制

500 ms

内存限制

128 MB

#include<bits/stdc++.h>
using namespace std;
double a,b,c,d,p,q,a1,b1,c1,lx,rx,x1,x2,x3;
int T;
double f(double x)
{
	return a*x*x*x+b*x*x+c*x+d;
}
double erfen(double l,double r,int a)
{
	
	double mid=(l+r)/2,ans;
	while(r-l>=1e-7)
	{
		mid=(l+r)/2;
		if(f(mid)*a>=0)r=mid,ans=mid;
		else l=mid;
	}
	return ans;
}
int main()
{
    cin>>T;
    for(int i=1;i<=T;i++)
    {
        cin>>a>>b>>c>>d>>p>>q;
        a1=3*a;
        b1=2*b;
        c1=c;
        double delta=sqrt(b1*b1-4*a1*c1);
        lx=(-b1-delta)/(2.0*a1);
        rx=(-b1+delta)/(2.0*a1);
        if(rx<lx)swap(rx,lx);
        int porn=(a>0);
        x1=erfen(p,lx,a);
        x2=erfen(lx,rx,-1*a);
        x3=erfen(rx,q,a);
        cout<<fixed<<setprecision(6)<<x1<<" "<<x2<<" "<<x3<<endl;
    }
}

 时间紧,注释先鸽一会儿

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值