Uva1592Database

Peter studies the theory of relational databases. Table in the relational database consists of values that are arranged in rows and columns.

There are different normal forms that database may adhere to. Normal forms are designed to minimize the redundancy of data in the database. For example, a database table for a library might have a row for each book and columns for book name, book author, and author's email.

If the same author wrote several books, then this representation is clearly redundant. To formally define this kind of redundancy Peter has introduced his own normal form. A table is in Peter's Normal Form (PNF) if and only if there is no pair of rows and a pair of columns such that the values in the corresponding columns are the same for both rows.

How to compete in ACM ICPCPeterpeter@neerc.ifmo.ru
How to win ACM ICPCMichaelmichael@neerc.ifmo.ru
Notes from ACM ICPC championMichaelmichael@neerc.ifmo.ru


The above table is clearly not in PNF, since values for 2rd and 3rd columns repeat in 2nd and 3rd rows. However, if we introduce unique author identifier and split this table into two tables -- one containing book name and author id, and the other containing book id, author name, and author email, then both resulting tables will be in PNF.

$\textstyle \parbox{.5\textwidth}{\begin{center}\begin{tabular}{\vert l\vert l......\hlineNotes from ACM ICPC champion & 2 \\\hline\end{tabular}\end{center}}$$\textstyle \parbox{.49\textwidth}{\begin{center}\begin{tabular}{\vert l\vert ......ine2 & Michael & michael@neerc.ifmo.ru \\\hline\end{tabular}\end{center}}$

Given a table your task is to figure out whether it is in PNF or not.

Input 

Input contains several datasets. The first line of each dataset contains two integer numbersn and m (1$ \le$n$ \le$10000, 1$ \le$m$ \le$10), the number of rows and columns in the table. The following n lines contain table rows. Each row hasm column values separated by commas. Column values consist of ASCII characters from space (ASCII code 32) to tilde (ASCII code 126) with the exception of comma (ASCII code 44). Values are not empty and have no leading and trailing spaces. Each row has at most 80 characters (including separating commas).

Output 

For each dataset, if the table is in PNF write to the output file a single word ``YES" (without quotes). If the table is not in PNF, then write three lines. On the first line write a single word ``NO" (without quotes). On the second line write two integer row numbers r1andr2 (1$ \le$r1,r2$ \le$n,r1$ \ne$r2), on the third line write two integer column numbers c1 andc2 (1$ \le$c1,c2$ \le$m,c1$ \ne$c2), so that values in columnsc1 andc2 are the same in rowsr1 andr2.

Sample Input 


3 3
How to compete in ACM ICPC,Peter,peter@neerc.ifmo.ru
How to win ACM ICPC,Michael,michael@neerc.ifmo.ru
Notes from ACM ICPC champion,Michael,michael@neerc.ifmo.ru
2 3
1,Peter,peter@neerc.ifmo.ru
2,Michael,michael@neerc.ifmo.ru


Sample Output 


NO
2 3
2 3
YES
 
思路:
枚举列,再一行行的遍历行,用map判断是否重复。
注意:拆分字符串不能错!
 
代码:
#include<cstdio>
#include<iostream>
#include<cstring>
#include<map>
using namespace std;

int n,m;

map<string,int> mp;
int Clock=0;

int a[10005][15]= {0};

void Make() {

	string y;
	getchar();
	for(int i=1; i<=n; i++) {
		int j=1;
		string b[20];
		while(j<=m) {
			char x=getchar();
			if(x=='\n') {
				j++;
			} else if(x==',') {
				j++;
			} else {
				b[j]+=x;
			}
		}

		for(int j=1; j<=m; j++) {
			if(!mp.count(b[j])) {
				mp[b[j]]=++Clock;
			}
			a[i][j]=mp[b[j]];
		}

	}

	return ;
}

struct node {
	int x,y;
	node() {}
	node(int one,int two) {
		x=one,y=two;
	}
	bool operator < (const node& xx) const {
		if(x<xx.x) return true;
		if(x==xx.x&&y<xx.y) return true;
		return false;
	}
};

void print(int x1,int x2,int x3,int x4) {
	printf("NO\n%d %d\n%d %d\n",x1,x2,x3,x4);
}

void Find() {

	for(int i=1; i<=m; i++) {
		for(int j=i+1; j<=m; j++) {
			map<node,int> USE;
			for(int k=1; k<=n; k++) {
				if(USE.count(node(a[k][i],a[k][j]))) {
					print(USE[node(a[k][i],a[k][j])],k,i,j);
					return ;
				}
				USE[node(a[k][i],a[k][j])]=k;
			}
		}
	}

	printf("YES\n");
	return ;

}

void init() {

	Clock=0;
	mp.clear();
	memset(a,0,sizeof(a));

}

int main() {

	while(scanf("%d%d",&n,&m)!=EOF) {

		init();
		Make();
		Find();

	}

	return 0;
}

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值