HDU1016素数环(深搜)

题目:

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

Input

n (0 < n < 20).

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input

6
8

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

题意:构造一个素数环,环要求相邻两数之和是素数。环的元素的个数小于等于20。输出素数环(字典序)。

方法:深搜

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int prime[12]={2,3,5,7,11,13,17,19,23,29,31,37};
int isprime[40];
int used[21],n,step;
int a[21];
int dfs(int step)
{
    int i;
    if(step==n+1&&isprime[a[1]+a[n]]==1)
    {
        for(i=1;i<n;i++)
        {
            printf("%d ",a[i]);
        }
        printf("%d\n",a[n]);
        return 0;//跳出当前dfs函数
    }
    else
    {
        for(i=2;i<=n;i++)
        {
            if(!used[i]&&isprime[i+a[step-1]])
            {
                used[i]=1;
                a[step]=i;
                dfs(step+1);
                used[i]=0;
            }
        }
    }
    return 0;//跳出当前dfs函数
}
int main()
{
    memset(isprime,0,sizeof(isprime));
    for(int i=0;i<12;i++)
    {
        isprime[prime[i]]=1;
    }
    int Case=1;
    a[1]=1;
    while(cin>>n)
    {
        memset(used,0,sizeof(used));
        printf("Case %d:\n",Case++);
        used[1]=1;
        dfs(2);
        cout<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值