Cleaning Shifts POJ - 2376(贪心)

Cleaning Shifts POJ - 2376

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T.

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval.

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.
Input

  • Line 1: Two space-separated integers: N and T

  • Lines 2…N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.

Output

  • Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.

Sample Input
3 10
1 7
3 6
6 10
Sample Output
2
Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

INPUT DETAILS:

There are 3 cows and 10 shifts. Cow #1 can work shifts 1…7, cow #2 can work shifts 3…6, and cow #3 can work shifts 6…10.

OUTPUT DETAILS:

By selecting cows #1 and #3, all shifts are covered. There is no way to cover all the shifts using fewer than 2 cows.

题意
给N头牛, 要求1 ~ T时间内都要有牛工作,求此时最少的牛的数量,若达不到,则输出-1。

题解
按照每头牛的开始时间排序.
(1)如果开始时间最小的都不等于1,则不可能达到要求。
(2)令 temp = 第一头牛的结束时间, 找一头牛开始时间小于 等于temp + 1,且tt记录最接近temp + 1,且 这头牛的结束时间最大
(3)如果最后一头牛的结束时间 不等于 T,则不可能达到要求。

#include<cstdio>
#include<queue>
#include<cstring>
#include<algorithm>
#define P pair<int, int>
using namespace std;

struct Cow{
   int s,t;
};
Cow a[25002];

bool cmp(Cow a, Cow b) {
    if(a.s == b.s) return a.t > b.t;
    return a.s < b.s;
}
int N, T;
int main()
{
	while(scanf("%d%d", &N, &T) != EOF){
		for(int i=0; i<N; i++)
			scanf("%d%d", &a[i].s, &a[i].t);
		sort(a, a+N, cmp);
		//cout << a[0].s<< endl;
   	if(a[0].s != 1) printf("-1\n");
	else{
		int ans = 1;
		int temp = a[0].t;
		int tt = temp;
		int i = 1;
		while(1){
			//找一头牛开始时间小于 等于temp + 1,且 这头牛的结束时间最大
			for(; i<N && a[i].s<=temp+1; i++){
			//tt记录a[i].s 最接近 temp + 1,且满足a[i].t
			//例如 1  7; 5  8; 6  10;虽然5  8 也满足,但是tt最终记录6 10
				if(a[i].t > tt){
					tt = a[i].t;
				}
			}
			if(tt > temp){
				temp = tt;
				ans++;
			}
			else break;
		}
		if(temp == T) printf("%d\n", ans);
		else printf("-1\n");
	}
    }	
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值