题目1433:FatMouse

时间限制:

内存限制:128 

特殊判题:否

提交:1345

解决:604

题目描述:

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain. 

输入:

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000. 

输出:

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain. 

样例输入:

5 3

7 2

4 3

5 2

20 3

25 18

24 15

15 10

-1 -1

样例输出:

13.333

31.500

 

//Fat Mouse 
//贪心策略,每次选择性价比最高的 
   
#include<stdio.h> 
#include<iostream> 
#include<algorithm> 
using namespace std; 
const int MAX = 1005; 
   
int M;//总钱数 
int N; 
  
typedef struct House 
{ 
    int weight;//重量  
    int price;//价格  
    float wtp;//性价比  
    void calwtp(){ 
        wtp = (float)weight/price; 
    } 
}House;  
House hs[MAX]; 
  
inline bool cmp(House x,House y) 
{ 
    return x.wtp>y.wtp?1:0; 
} 
  
int
main(void) 
{ 
    while(~scanf("%d%d",&M,&N)&& M!=-1 && N!=-1) 
    { 
        float ans = 0;//最高所得重量  
        int i; 
        for(i=0;i<N;i++) 
        { 
            scanf("%d%d",&hs[i].weight,&hs[i].price); 
            hs[i].calwtp(); 
        } 
        sort(hs,hs+N,cmp); 
          
        i=0; 
        while(M && i<N) 
        { 
            if((M-hs[i].price)<0) 
            { 
                ans += hs[i].weight*(float)M/hs[i].price; 
                M = 0; 
            } 
            else
            { 
                ans += hs[i].weight; 
                M -= hs[i].price; 
            } 
            i++; 
        } 
          
        printf("%.3f\n",ans); 
    } 
    return 0; 
} 
/************************************************************** 
    Problem: 1433 
    User: ranchothu 
    Language: C++ 
    Result: Accepted 
    Time:10 ms 
    Memory:1536 kb 
****************************************************************/


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值