数据结构实验之栈与队列一:进制转换
Time Limit: 1000 ms Memory Limit: 65536 KiB
Problem Description
输入一个十进制非负整数,将其转换成对应的 R (2 <= R <= 9) 进制数,并输出。
Input
第一行输入需要转换的十进制非负整数;
第二行输入 R。
Output
输出转换所得的 R 进制数。
Sample Input
1279
8
Sample Output
2377
Hint
Source
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
int a[1010];
int main()
{
int i,r,n,t,s;
int top=0;
scanf("%d %d",&n,&r);
memset(a,0,sizeof(a));
if(n==0)printf("0\n");
else
{
while(n!=0)
{
s=n%r;
n=n/r;
a[++top]=s;
}
while(top!=0)
{
printf("%d",a[top--]);
}
printf("\n");
}
return 0;
}
是真的饿的无法思考了
效率极慢