3343数据结构实验之二叉树四:(先序中序)还原二叉树

数据结构实验之二叉树四:(先序中序)还原二叉树

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic

Problem Description

给定一棵二叉树的先序遍历序列和中序遍历序列,要求计算该二叉树的高度。

Input

输入数据有多组,每组数据第一行输入1个正整数N(1 <= N <= 50)为树中结点总数,随后2行先后给出先序和中序遍历序列,均是长度为N的不包含重复英文字母(区分大小写)的字符串。

 

Output

 输出一个整数,即该二叉树的高度。

Sample Input

9 
ABDFGHIEC
FDHGIBEAC

Sample Output

5

Hint

Source

xam


注:代码中含有我自己做的别的题懒得删,就没动,此题的代码主要是get_build(),high(),main()三个函数,其他的不用看。

当然直接提交代码是可以AC的

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
typedef struct node
{
    char data;
    struct node *left;
    struct node *right;
}tree;
char str1[100],str2[100];
tree *root,*link[54];


//str1为前序,str2为中序 求层序
tree *get_build(int len,char *str1,char *str2)
{
    if(len==0)
        return NULL;
    int i;
    tree *root;
    root=(tree *)malloc(sizeof(tree));
    root->data=str1[0];
    for(i=0;i<len;i++)
    {
        if(str2[i]==root->data)
            break;
    }
    root->left=get_build(i,str1+1,str2);
    root->right=get_build(len-i-1,str1+i+1,str2+i+1);
    return root;
}

int high(tree *root)//求二叉树的高度
{
    int n,m;
    if(root==NULL)
        return 0;
    else
    {
        n=high(root->left);
        m=high(root->right);
        if(n>m)
            return n+1;
        else
            return m+1;
    }
}


void ans(tree *root)//层序遍历序列
{
    if (root)
    {
        int i=0,j=0;
        link[j++]=root;
        while(i<j)
        {
            if(link[i])
            {
                link[j++]=link[i]->left;
                link[j++]=link[i]->right;
                printf("%c",link[i]->data);
            }
            i++;
        }
    }
}


void post(tree *root)//后序遍历序列
{
    if (root)
    {
        post(root->left);
        post(root->right);
        printf("%c",root->data);
    }

}

 //str1中序遍历 ,str2后序遍历 求先序遍历
tree *creat(int len,char *str1,char *str2)
{
    if(len==0)
        return NULL;
    int i;
    tree *root;
    root = (tree *)malloc(sizeof(tree));
    root->data=str2[len-1];
    printf("%c",root->data);
    for(i=0; i<len; i++)
    {
        if(str1[i]==str2[len-1])
            break;
    }
    root->left =creat(i,str1,str2);
    root->right = creat(len-i-1,str1+i+1,str2+i);
    return root;
}




int main()
{
    int t,len;

    while(scanf("%d",&t)!=EOF)
    {
        //memset(str1,0,sizeof(str1));
        //memset(str2,0,sizeof(str2));
        scanf("%s %s",str1,str2);
        //len=strlen(str1);
        root=get_build(t,str1,str2);
        printf("%d\n",high(root));
        //post(root);
        //printf("\n");
        //ans(root);
        //printf("\n");
        //root=creat(len,str1,str2);
        //printf("\n");
    }

    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值