1081 检查密码 (15 分)

1081 检查密码 (15 分)

本题要求你帮助某网站的用户注册模块写一个密码合法性检查的小功能。该网站要求用户设置的密码必须由不少于6个字符组成,并且只能有英文字母、数字和小数点 .,还必须既有字母也有数字。

输入格式:

输入第一行给出一个正整数 N(≤ 100),随后 N 行,每行给出一个用户设置的密码,为不超过 80 个字符的非空字符串,以回车结束。

输出格式:

对每个用户的密码,在一行中输出系统反馈信息,分以下5种:

  • 如果密码合法,输出Your password is wan mei.
  • 如果密码太短,不论合法与否,都输出Your password is tai duan le.
  • 如果密码长度合法,但存在不合法字符,则输出Your password is tai luan le.
  • 如果密码长度合法,但只有字母没有数字,则输出Your password needs shu zi.
  • 如果密码长度合法,但只有数字没有字母,则输出Your password needs zi mu.

输入样例:

5
123s
zheshi.wodepw
1234.5678
WanMei23333
pass*word.6

输出样例:

Your password is tai duan le.
Your password needs shu zi.
Your password needs zi mu.
Your password is wan mei.
Your password is tai luan le.

错误代码如下:

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
int main()
{
    int n;
    int len,f,l,l1,l2,l3;
    char ch[80];
    scanf("%d",&n);
    for(int i=0;i<n;i++)
    {
        f=0,len=0;
        scanf("%s",ch);
        len = strlen(ch);
        l=0;l1=0;l2=0;l3=0;
        if(len<6) printf("Your password is tai duan le.\n");
        else
        {
            for(int j=0;j<len;j++)
           {
            if((ch[j]>='a'&&ch[j]<='z')||(ch[j]>='A'&&ch[j]<='Z')) l1++;
            else if(ch[j]>='0'&&ch[j]<='9') l2++;
            else if(ch[j]=='.') l3++;
            else l++;

           }
           if(l1+l2+l3==len&&l3<len)
            {
            if(l1==0) printf("Your password needs zi mu.\n");
            else if(l2==0) printf("Your password needs shu zi.\n");
            else printf("Your password is wan mei.\n");
            }
            else if(l!=0||l1+l2==0)
                printf("Your password is tai luan le.\n");
        }
    }
    return 0;
}

分析:记录字母、数字的个数分别为 l1,l2,每一行字符串的长度为len,判断 l1,l2 与字符串长度 可知 字符串是否合法。
部分错误,正在改正! 

注意:1、当用scanf函数输入字符串时,字符串不能含有空格,否则空格将作为结束符!

           2、定义字符串的长度为 len ,输入的字符串长度要小于 len ,留一个字节用于存放字符串结束标志 ‘ \0’.

代码如下:

#include <stdio.h>
#include <stdlib.h>
#include <string.h>

int main()
{
    int n;
    int len,l,l1,l2,l3;
    char ch[100];
    scanf("%d",&n);
    getchar(); //消除空格
    for(int i=0;i<n;i++)
    {
        
        len=0;
        gets(ch);
        len = strlen(ch);
        l=0;l1=0;l2=0;l3=0;
        if(len<6) printf("Your password is tai duan le.\n");
        else
        {
            for(int j=0;j<len;j++)
           {
            if((ch[j]>='a'&&ch[j]<='z')||(ch[j]>='A'&&ch[j]<='Z')) l1++;
            else if(ch[j]>='0'&&ch[j]<='9') l2++;
            else if(ch[j]=='.') l3++;
            else l++;

           }
           if(l1+l2+l3==len&&l3<len)
            {
            if(l1==0) printf("Your password needs zi mu.\n");
            else if(l2==0) printf("Your password needs shu zi.\n");
            else printf("Your password is wan mei.\n");
            }
            else if(l!=0||l1+l2==0)
                printf("Your password is tai luan le.\n");
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值