数据结构实验之二叉树二:遍历二叉树


数据结构实验之二叉树二:遍历二叉树
Time Limit: 1000MS Memory limit: 65536K

题目描述

已知二叉树的一个按先序遍历输入的字符序列,如abc,,de,g,,f,,, (其中,表示空结点)。请建立二叉树并按中序和后序的方式遍历该二叉树。

输入

连续输入多组数据,每组数据输入一个长度小于50个字符的字符串。

输出

每组输入数据对应输出2行:
第1行输出中序遍历序列;
第2行输出后序遍历序列。

 

示例输入

abc,,de,g,,f,,,

示例输出

cbegdfa
cgefdba

提示

 

来源

 xam

示例程序

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
char ch[51];
int len,len1;
struct node
{
 char data;
 struct node *lchild,*rchild;
};
struct node *CreateTree()  //建树
{
 struct node *root;
 if(len<len1)
 {
  char c=ch[len++];
   if(c==',')
    return NULL;
   else
   {
     root=(struct node *)malloc(sizeof(struct node));
     root->data=c;      //根
     root->lchild=CreateTree();
     root->rchild=CreateTree();

   }
 }
 return root;
}
void LDR(struct node *root)
{
 if(root)  //树不为空
 {
LDR(root->lchild);
printf("%c",root->data);
LDR(root->rchild);
 }
}
void LRD(struct node *root)
{
 if(root)
 {
 LRD(root->lchild);
 LRD(root->rchild);
 printf("%c",root->data);
 }
}
int main()
{
 struct node *root;
 while(~scanf("%s",ch))
 {
  len=0;
  len1=strlen(ch);
  root=CreateTree();
        LDR(root);
        printf("\n");
        LRD(root);
        printf("\n");

 }

return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值