简单枚举类型——植物与颜色

Problem Description
 请定义具有red, orange, yellow, green, blue, violet六种颜色的枚举类型color,根据输入的颜色名称,输出以下六种植物花朵的颜色:
Rose(red), Poppies(orange), Sunflower(yellow), Grass(green), Bluebells(blue), Violets(violet)。如果输入的颜色名称不在枚举类型color中,例如输入purple,请输出I don't know about the color purple.
 
Input
 输入数据有多行,每行有一个字符串代表颜色名称,颜色名称最多30个字符,直到文件结束为止。
Output
 输出对应颜色的植物名称,例如:Bluebells are blue. 如果输入的颜色名称不在枚举类型color中,例如purple, 请输出I don't know about the color purple.
 
Example Input
blue
yellow
purple
Example Output
Bluebells are blue.
Sunflower are yellow.
I don't know about the color purple.
Hint
 请用枚举类型实现。 
import java.util.Scanner;

public class Main {
	public static void main(String[] args) {
		Scanner in = new Scanner(System.in);
		while(in.hasNext()){
			String a = in.nextLine();
			Color color = new Color(a);
			color.show();
		}
		in.close();
	}
}
class Color{
	String a;
	public Color(String a){
		this.a = a;
	}
	public void show(){
		if(a.compareTo("red")==0)
			System.out.println("Rose are red.");
		else if(a.compareTo("orange")==0)
			System.out.println("Poppies are orange.");
		else if(a.compareTo("yellow")==0)
			System.out.println("Sunflower are yellow.");
		else if(a.compareTo("green")==0)
			System.out.println("Grass are green.");
		else if(a.compareTo("blue")==0)
			System.out.println("Bluebells are blue.");
		else if(a.compareTo("violet")==0)
			System.out.println("Violets are violet.");
		else  
			System.out.println("I don't know about the color " + a + ".");
	}
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值