在输入数据的第一行有两个数:N——钉子的数目(1 <= N <= 100),R——钉子的半径。所有的钉子半径
相同。接下来有N行数据,每行有两个空格隔开的实数代表钉子中心的坐标。坐标的绝对值不会超过
100。钉子的坐标从某一颗开始按照顺时针或逆时针的顺序给出。不同的钉子不会重合。
Output
输出一个实数(小数点后保留两位)————红线的长度。
Example Input
4 1
0.0 0.0
2.0 0.0
2.0 2.0
0.0 2.0
Example Output
14.28
Hint
Author
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner in = new Scanner(System.in);
int n = in.nextInt();
int r = in.nextInt();
double a[]=new double[201];
RedLine line = new RedLine(n,r);
int i;
for(i = 0; i < n*2; i++)
a[i] = in.nextDouble();
line.Length(a);
in.close();
}
}
class RedLine{
int n;
int r;
public RedLine(int n,int r){
this.n = n;
this.r = r;
}
public void Length(double f[]){
int i;
double sum = 0;
double q;
for(i = 2; i < n*2-1; i = i+2){
q = (f[i]-f[i-2])*(f[i]-f[i-2])+(f[i+1]-f[i-1])*(f[i+1]-f[i-1]);
sum = sum + Math.sqrt(q);
}
q = (f[2*n-2]-f[0])*(f[2*n-2]-f[0])+(f[2*n-1]-f[1])*(f[2*n-1]-f[1]);
sum = sum + Math.sqrt(q);
sum = sum +Math.PI*r*2;
System.out.printf("%.2f\n", sum);
}
}