尺取法(总结+模板+例题)

什么是尺取法:反复地推进区间的开头和末尾,来求取满足条件的最小区间的方法称为尺取法

1、  什么情况下能使用尺取法?  

2、何时推进区间的端点?

3、如何推进区间的端点?

4、何时结束区间的枚举?

 

尺取法通常适用于选取区间有一定规律,或者说所选取的区间有一定的变化趋势的情况,通俗地说,在对所选取区间进行判断之后,我们可以明确如何进一步有方向地推进区间端点以求解满足条件的区间,如果已经判断了目前所选取的区间,但却无法确定所要求解的区间如何进一步得到根据其端点得到,那么尺取法便是不可行的。首先,明确题目所需要求解的量之后,区间左右端点一般从最整个数组的起点开始,之后判断区间是否符合条件在根据实际情况变化区间的端点求解答案。

尺取法的思路:

以 l = r = sum = 0 初始化
只要依然有sum < s,就不断将sum增加a[r],并将r增加1
如果第2步无法满足sum >= s则终止,否则更新ans = min(ans, r - l);
将sum减去a[l],l增加1然后回到第2步

模板:

void solve(){
	int ans=n+1;
	int l=0,r=0,sum=0;
	for(;;){
		while(r<n&&sum<s){//向右推进 
			sum+=a[r];
			r++;
		}
		if(sum<s)
		    break;
		ans=min(ans,r-l);
		sum-=a[l];//向左推进 
		l++;
	}
	if(ans>n)
	    ans=0;
	cout<<ans<<endl;
}

例题:

Subsequence

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3
#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<queue>
#include<stack>
#include<set>
#include<map>
#include<vector>
#include<cmath>
const int maxn=1e5+5;
typedef long long ll;
using namespace std;
int a[100005];
int main(){
	int t;
	scanf("%d",&t);
	while(t--){
		int n,f;
		scanf("%d%d",&n,&f);
		for(int i=0;i<n;i++){
			scanf("%d",&a[i]);
		}
		int res=n+1;
		int s=0,t=0,num=0;
		for(;;){
			while(t<n&&num<f){
				num+=a[t];
				t++;
			}
			if(num<f)
			    break;
			res=min(res,t-s);
			num-=a[s];
			s++;
		}
		if(res>n)
		     res=0;
	    printf("%d\n",res);
	}
	return 0; 
} 

POJ3320 Jessica's Reading Problem

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 18992 Accepted: 6529

Description

Jessica's a very lovely girl wooed by lots of boys. Recently she has a problem. The final exam is coming, yet she has spent little time on it. If she wants to pass it, she has to master all ideas included in a very thick text book. The author of that text book, like other authors, is extremely fussy about the ideas, thus some ideas are covered more than once. Jessica think if she managed to read each idea at least once, she can pass the exam. She decides to read only one contiguous part of the book which contains all ideas covered by the entire book. And of course, the sub-book should be as thin as possible.

A very hard-working boy had manually indexed for her each page of Jessica's text-book with what idea each page is about and thus made a big progress for his courtship. Here you come in to save your skin: given the index, help Jessica decide which contiguous part she should read. For convenience, each idea has been coded with an ID, which is a non-negative integer.

Input

The first line of input is an integer P (1 ≤ P ≤ 1000000), which is the number of pages of Jessica's text-book. The second line contains P non-negative integers describing what idea each page is about. The first integer is what the first page is about, the second integer is what the second page is about, and so on. You may assume all integers that appear can fit well in the signed 32-bit integer type.

Output

Output one line: the number of pages of the shortest contiguous part of the book which contains all ideals covered in the book.

Sample Input

5
1 8 8 8 1

Sample Output

2
#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<queue>
#include<stack>
#include<set>
#include<map>
#include<vector>
#include<cmath>
const int maxn=1e5+5;
typedef long long ll;
using namespace std;
int main(){
	int m,a[maxn];
	scanf("%d",&m);
    set<int> all;
    map<int,int> count;
	for(int i=0;i<m;i++){
		scanf("%d",&a[i]);
		all.insert(a[i]); 
	}
	int n=all.size() ;
	int ans=m+1;
	int l=0,r=0,sum=0;
	for(;;){
		while(r<m&&sum<n){//向右推进 
			if(count[a[r++]]++==0){//有新的出现 
				sum++;
			}
		}
		if(sum<n)
		    break;
		ans=min(ans,r-l);
        if(--count[a[l++]]==0)
            sum--;
	}
	cout<<ans<<endl;
} 

3.https://blog.csdn.net/red_red_red/article/details/89842519

 


 

 

  • 1
    点赞
  • 5
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值