POJ 3342

Party at Hali-Bula
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 4854 Accepted: 1716

Description

Dear Contestant,

I'm going to have a party at my villa at Hali-Bula to celebrate my retirement from BCM. I wish I could invite all my co-workers, but imagine how an employee can enjoy a party when he finds his boss among the guests! So, I decide not to invite both an employee and his/her boss. The organizational hierarchy at BCM is such that nobody has more than one boss, and there is one and only one employee with no boss at all (the Big Boss)! Can I ask you to please write a program to determine the maximum number of guests so that no employee is invited when his/her boss is invited too? I've attached the list of employees and the organizational hierarchy of BCM.

Best,
--Brian Bennett

P.S. I would be very grateful if your program can indicate whether the list of people is uniquely determined if I choose to invite the maximum number of guests with that condition.

Input

The input consists of multiple test cases. Each test case is started with a line containing an integer n (1 ≤ n ≤ 200), the number of BCM employees. The next line contains the name of the Big Boss only. Each of the followingn-1 lines contains the name of an employee together with the name of his/her boss. All names are strings of at least one and at most 100 letters and are separated by blanks. The last line of each test case contains a single 0.

Output

For each test case, write a single line containing a number indicating the maximum number of guests that can be invited according to the required condition, and a word Yes or No, depending on whether the list of guests is unique in that case.

Sample Input

6
Jason
Jack Jason
Joe Jack
Jill Jason
John Jack
Jim Jill
2
Ming
Cho Ming
0

Sample Output

4 Yes
1 No

Source

树形DP,,,判断唯一也简单:
对于一个i如果不是叶子节点,
并且它的子节点数大于1,并且取不取都一样。即:dp[i][0]=dp[i][1],那么结果不唯一!
AC代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<map>
#include<string>
#include<cmath>
#include<algorithm>
#define max(x,y)(x>y?x:y)
using namespace std;
const int MAXN=210;
int dp[MAXN][2];   //dp[i][0]表示不选,dp[i][1]表示选
int n,m,f;
int head[MAXN];
int num[MAXN];
map<string,int>Q;
struct node
{
	int v,next;
}p[MAXN];
void add(int v,int u)
{
	num[u]++;
	p[m].v=v;
	p[m].next=head[u];
	head[u]=m++;
}
void dfs(int i)
{
	if(head[i]==-1)return;
	for(int j=head[i];j!=-1;j=p[j].next)
	{
		dfs(p[j].v);
		dp[i][0]+=max(dp[p[j].v][1],dp[p[j].v][0]);
		dp[i][1]+=dp[p[j].v][0];
	}
	//当对于一个i节点不是叶子,并且儿子不只1个,并且dp[i][0]=dp[i][1]不唯一
	if(dp[i][1]==dp[i][0]&&num[i]>1||n==2)f=1;
}
int main()
{
	int i;
	char u[MAXN],v[MAXN];
	while(scanf("%d",&n)!=EOF,n)
	{
		int k=1;
		Q.clear();
		scanf("%s",u);
		Q[u]=k++;
		memset(num,0,sizeof(num));
		for(i=1;i<=n;dp[i][0]=0,dp[i++][1]=1);
		memset(head,-1,sizeof(head));
		f=m=0;
		for(i=1;i<n;i++)
		{
			scanf("%s%s",u,v);
			if(Q[u]==0)Q[u]=k++;
			if(Q[v]==0)Q[v]=k++;
		//	printf("\n%d %d\n",Q[u],Q[v]);
			add(Q[u],Q[v]);
		}
		dfs(1);
		printf("%d ",max(dp[1][0],dp[1][1]));
		if(f)puts("No");
		else puts("Yes");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值