HDU 1002 大数加法

A + B Problem II

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110


#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
char a[1050],b[1050],c[1050],d[1050],e[1050];
int main()
{
	int t,j,i,lena,lenb,lenc,num;
	scanf("%d",&t);
    for(i=1;i<=t;i++)
	{
		scanf("%s%s",a,b);
		memset(c,0,sizeof(c));
		memset(d,0,sizeof(d));
		memset(e,0,sizeof(e));
		lena=strlen(a);lenb=strlen(b);
		  lenc=max(lena,lenb);num=0;
		for(j=0;j<=lena-1;j++)
		{
			c[lena-j-1]=a[j]-'0';
		}
		for(j=0;j<=lenb-1;j++)
		{
			d[lenb-j-1]=b[j]-'0';
		}
		for(j=0;j<=lenc;j++)
		{
			 e[j]=c[j]+d[j]+num;
			if(e[j]>9)
			{
				e[j]-=10;
				num=1;
			}
			else
			{
				num=0;
			}
		}
		if(e[lenc]==0)
		  lenc--;
		i==1?printf("Case %d:\n%s + %s = ",i,a,b):printf("\nCase %d:\n%s + %s = ",i,a,b);
		for(j=lenc;j>=0;j--)
		{
			printf("%d",e[j]);
		}
		printf("\n");
	}
} 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值