PAT (Advanced Level) Practice1016 Phone Bills (25 分)

3 篇文章 0 订阅
2 篇文章 0 订阅

[ 题目链接 ]

A long-distance telephone company charges its customers by the following rules:
Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.
The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00
02:00, and so on for each hour in the day.
The next line contains a positive number N (<= 1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word “on-line” or “off-line”.
For each test case, all dates will be within a single month. Each “on-line” record is paired with the chronologically next record for the same customer provided it is an “off-line” record. Any “on-line” records that are not paired with an “off-line” record are ignored, as are “off-line” records not paired with an “on-line” record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.
Bills must be printed in alphabetical order of customers’ names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:
10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line
Sample Output:
CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

题意

计算电话费。输入第一行给出二十四小时的话费价格,第二行给出一个不超过1000的正数N,接下来N条记录,每条记录给出用户名字,时刻(月:日:时:分),状态(接通/挂断)。输出每个人的月账单。格式为:用户名,月份,每个时段(以及分钟,价格),这月总计金额。

思路

我们可以用结构体读入存储每条记录,然后对它们进行排序。首先把名字相同的放在一起,时刻从小到大排列。接着,我们就可以从第一条记录开始往后依次计算了。当前后两条记录的用户不同时,输出total amount,以及下一个用户名和月份。最后一条记录处理完之后要输出total amount。美元和美分之间100的换算率。

代码

#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<iostream>
#include<vector>
using namespace std;

struct node{
    string name;
    int mm,dd,hh,ss;
    bool state;
};

int price[25],n;

bool cmp(node x, node y)
{
    if(x.name.compare(y.name)!=0)
        return x.name<y.name;
    if(x.mm!=y.mm) return x.mm<y.mm;
    if(x.dd!=y.dd) return x.dd<y.dd;
    if(x.hh!=y.hh) return x.hh<y.hh;
    return x.ss<y.ss;
}

double get_bill(node x, node y, int& time)
{   //计算单次通话账单
    int money=0;
    while(x.ss>y.ss || x.hh>y.hh || x.dd >y.dd){//每次增加一分钟,直到两个时刻相同
        time++;
        money += price[y.hh];
        y.ss++;
        if(y.ss>=60){
            y.ss=0;
            y.hh++;
        }
        if(y.hh>=24){
            y.hh=0;
            y.dd++;
        }
    }
    return money/100.0;
}

int main()
{
    for(int i=0;i<24;i++) cin>>price[i];
    cin>>n;
    vector<node>data(n);
    string state;
    for(int i=0;i<n;i++){
        cin>>data[i].name;
        scanf("%d:%d:%d:%d",&data[i].mm,&data[i].dd,&data[i].hh,&data[i].ss);
        cin>>state;
        if(state.compare("on-line")==0){
            data[i].state=true;
        } else data[i].state=false;
    }
    sort(data.begin(),data.end(),cmp);
    node tmp=data[0];
    int on=-1,off;//记录接通、断开记录的下标
    if(tmp.state) on=0;
    double total=0.0,bill=0.0;
    bool flag=false;
    for(int i=1;i<n;i++){//依次处理每条记录
        if(tmp.name.compare(data[i].name)==0){//本条记录和上一条是同一个用户
            if(data[i].state) on=i;
            else off=i;
            if(off==on+1){//本条记录和上条记录为一次通话
                if(!flag){//之前未输出过该用户单次通话账单
                    cout<<data[i].name<<" ";
                    printf("%02d\n",data[i].mm);
                    flag=true;
                }
                int time=0;
                bill=0.0;
                bill=get_bill(data[i],tmp,time);
                total += bill;
                printf("%02d:%02d:%02d %02d:%02d:%02d",tmp.dd,tmp.hh,tmp.ss,data[i].dd,data[i].hh,data[i].ss);
                cout<<" "<<time;
                printf(" $%.2f\n",bill);
            }
        }
        else{    //和tmp的不是同一个用户
            if(flag){    //若有通话时长,就输出
                printf("Total amount: $%.2f\n",total);
                flag=false;
                total=0.0;
            }
        }
        tmp=data[i];//更新tmp为当前记录
        if(data[i].state) on=i;
        else off=i;
        if(i==n-1 && flag) printf("Total amount: $%.2f\n",total);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值