3905 - Meteor

链接:https://icpcarchive.ecs.baylor.edu/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=1906

The famous Korean internet company nhn has provided an internet-based photo service which allows The famous Korean internet company users to directly take a photo of an astronomical phenomenon in space by controlling a high-performance telescope owned by nhn. A few days later, a meteoric shower, known as the biggest one in this century, is expected. nhn has announced a photo competition which awards the user who takes a photo containing as many meteors as possible by using the photo service. For this competition, nhn provides the information on the trajectories of the meteors at their web page in advance. The best way to win is to compute the moment (the time) at which the telescope can catch the maximum number of meteors.

You have n meteors, each moving in uniform linear motion; the meteormi moves along the trajectory pi + t×vi over time t , where t is a non-negative real value,pi is the starting point of mi and vi is the velocity ofmi . The point pi = (xi,yi) is represented by X -coordinatexi and Y -coordinateyi in the (X,Y) -plane, and the velocity vi = (ai,bi) is a non-zero vector with two components ai and bi in the(X, Y) -plane. For example, if pi = (1, 3) and vi = (-2, 5) , then the meteormi will be at the position (0, 5.5) at timet = 0.5 because pi +t×vi = (1, 3) + 0.5×(-2, 5) = (0, 5.5) . The telescope has a rectangular frame with the lower-left corner (0, 0) and the upper-right corner(w, h) . Refer to Figure 1. A meteor is said to be in the telescope frame if the meteor is in the interior of the frame (not on the boundary of the frame). For exam! ple, in Figure 1,p2, p3, p4 , andp5 cannot be taken by the telescope at any time because they do not pass the interior of the frame at all. You need to compute a time at which the number of meteors in the frame of the telescope is maximized, and then output the maximum number of meteors.

\epsfbox{p3905.eps}

Input 

Your program is to read the input from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case starts with a line containing two integersw and h (1$ \le$w,h$ \le$100, 000) , the width and height of the telescope frame, which are separated by single space. The second line contains an integer n , the number of input points (meteors),1$ \le$n$ \le$100, 000 . Each of the next n lines contain four integersxi, yi, ai , andbi ; (xi,yi) is the starting point pi and(ai, bi) is the nonzero velocity vectorvi of the i -th meteor;xi and yi are integer values between -200,000 and 200,000, andai and bi are integer values between -10 and 10. Note that at least one ofai and bi is not zero. These four values are separated by single spaces. We assume that all starting pointspi are distinct.

Output 

Your program is to write to standard output. Print the maximum number of meteors which can be in the telescope frame at some moment.

Sample Input 

2 
4 2 
2 
-1 1 1 -1 
5 2 -1 -1 
13 6 
7 
3 -2 1 3 
6 9 -2 -1 
8 0 -1 -1 
7 6 10 0 
11 -2 2 1 
-2 4 6 -1 
3 2 -5 -1

Sample Output 

1 
2

分析:

流星的轨迹是没有意义的,有用的只是每一点出现的时间,type=0,1只是左右端点的记录

代码:

#include<cstdio>
#include<algorithm>
using namespace std;
int w,h,n;
const int maxn=100000+10;

void update(int x,int a,int w,double& L,double& R)
{
	if(a==0)
	{
		if(x<=0||x>=w)
			R=L-1;
	}
	else if(a>0)
	{
		L=max(L,-(double)x/a);
		R=min(R,(double)(w-x)/a);
	}
	else
	{
		L=max(L,(double)(w-x)/a);
		R=min(R,-(double)x/a);
	}
}

struct Event
{
	double x;
	int type;
	bool operator < (const Event& a) const
	{
		return x<a.x||(x==a.x && type>a.type);
	} 
};
Event event[2*maxn];

int main()
{
	int T,x,y,a,b;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d%d%d",&w,&h,&n);
		int e=0;
		for(int i=0;i<n;i++)
		{
			scanf("%d%d%d%d",&x,&y,&a,&b);
			double L=0,R=1e9;
			update(x,a,w,L,R);
			update(y,b,h,L,R);
			if(R>L)
			{
				event[e++]=(Event){L,0};
				event[e++]=(Event){R,1};
			}
		}
		sort(event,event+e);
		int cnt=0,ans=0;
		for(int i=0;i<e;i++)
		{
			if(event[i].type==0)
				ans=max(ans,++cnt);
			else
				cnt--;//遇到左端就加一,遇到右端就减一 ;真的是好精彩的算法;太美妙了 
		}
		printf("%d\n",ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值