Unsupported major.minor version 51.0报错

  今天项目一更新,什么都没有修改,然后就一直在报错

  报错的内容是:unsupported major.minor version 51.0 ,也不知道怎么回事

  后百度得知:低版本的 JVM 无法加载高版本的 class 文件造成的,也就是说:不同的jdk版本使用的major.minor不同,所以会出现这种问题

  大概得原因:而这个错误指向的是我们自己打包的一个jar文件,后有在群里询问,因为他们打包这个jar的时候,使用的jdk1.7,所以我在jdk1.6里面使用,所以会报这个错

  解决办法:1)把jdk换成1.7 (ps:jdk不同的版本都可以安装,但是在没一个项目中,只能选择一个,可以安装不同的版本,按照不同的项目需要使用)

                 2)把自己打包的jar文件的项目放到jdk1.6的环境下面生成

  最后的解决:选择了1. 下载了jdk1.7 ,然后安装,不用设置环境变量这些。只要在myeclipse中需要的项目中,在java build path 里面的jdk换成1.7 运行的,然后tomcat的jdk也换成jdk1.7 ,我一开始,myeclipse不关闭启动,好像不行,最后我又重新启动一下myeclipse ,一运行,可以

    网上有一种是说:java compiler-->compiler compliance level 换成自己的版本,我这种换过了。不行。

     所以做个记录,下次遇到了。就好解决了。


阅读更多
版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/rendeyishi/article/details/53993947
个人分类: 整理
想对作者说点什么? 我来说一句

Unsupported major.minor version 51.0

2015年06月08日 89KB 下载

没有更多推荐了,返回首页

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭