PAT A1030 Travel Plan (30分)

题目链接https://pintia.cn/problem-sets/994805342720868352/problems/994805464397627392

题目描述
A traveler’s map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.

输入
Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (≤500) is the number of cities (and hence the cities are numbered from 0 to N−1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:

City1 City2 Distance Cost

where the numbers are all integers no more than 500, and are separated by a space.

输出
For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.

样例输入
4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20

样例输出
0 2 3 3 40

代码

#include <bits/stdc++.h>
using namespace std;

//n<=500可用邻接矩阵表示
const int maxn = 510;
const int INF = 0x3f3f3f3f;
int n,m;
int G[maxn][maxn]; //存距离
int cost[maxn][maxn]; //存花费
int d[maxn], c[maxn]; //存最短距离和最短花费
int pre[maxn]; //pre[u]=v v是u在最短路径中的前一个节点
bool vis[maxn];

//d[] s到每一点的最短距离
void Dijkstra(int s)
{
    vis[s] = true;
    fill(vis, vis + maxn, false);
    fill(d, d + maxn, INF);
    fill(c, c + maxn, INF);
    d[s] = 0;
    c[s] = 0;
    for(int i = 0; i < n; ++i) pre[i] = i;
    for(int i = 0; i < n; ++i){
        if(vis[i]) continue;
        //找未访问节点中d[]最小的
        int minn = INF, u = -1;
        for(int j = 0; j < n; ++j){
            if(!vis[j] && d[j] < minn){
                minn = d[j];
                u = j;
            }
        }
        if(u == -1) return;
        vis[u] = true;
        for(int v = 0; v < n; ++v){
            if(!vis[v] && G[u][v] != INF){
                if(d[u] + G[u][v] < d[v]){
                    d[v] = d[u] + G[u][v];
                    c[v] = c[u] + cost[u][v];
                    pre[v] = u;
                }
                else if(d[u] + G[u][v] == d[v] && c[u] + cost[u][v] < c[v]){
                    c[v] = c[u] + cost[u][v];
                    pre[v] = u;
                }
            }
        }
    }
}
//递归求最短路径
void DFS(int s, int v)
{
    if(v == s){
        printf("%d ",v);
        return;
    }
    DFS(s, pre[v]);
    printf("%d ",v);
}

int main()
{
    int s,e;
    fill(G[0], G[0] + maxn * maxn, INF);//首地址,尾地址,初始化的值
    //fill(cost[0], cost[0] + maxn * maxn, INF); //cost数组其实不必初始化
    scanf("%d%d%d%d",&n,&m,&s,&e);
    for(int i = 0; i < m; ++i){
        int a,b,dis,cos;
        scanf("%d%d%d%d",&a,&b,&dis,&cos);
        G[a][b] = G[b][a] = dis;
        cost[a][b] = cost[b][a] = cos;
    }
    Dijkstra(s);
    DFS(s, e);
    printf("%d %d",d[e], c[e]);
    return 0;
}

weixin151云匹面粉直供微信小程序+springboot后端毕业源码案例设计 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值