POJ3694 Network(求桥的数目,lca,Tarjan)

Description

A network administrator manages a large network. The network consists
of N computers and M links between pairs of computers. Any pair of
computers are connected directly or indirectly by successive links, so
data can be transformed between any two computers. The administrator
finds that some links are vital to the network, because failure of any
one of them can cause that data can’t be transformed between some
computers. He call such a link a bridge. He is planning to add some
new links one by one to eliminate all bridges.

You are to help the administrator by reporting the number of bridges
in the network after each new link is added.

Input

The input consists of multiple test cases. Each test case starts with
a line containing two integers N(1 ≤ N ≤ 100,000) and M(N - 1 ≤ M ≤
200,000). Each of the following M lines contains two integers A and B
( 1≤ A ≠ B ≤ N), which indicates a link between computer A and B.
Computers are numbered from 1 to N. It is guaranteed that any two
computers are connected in the initial network. The next line contains
a single integer Q ( 1 ≤ Q ≤ 1,000), which is the number of new links
the administrator plans to add to the network one by one. The i-th
line of the following Q lines contains two integer A and B (1 ≤ A ≠ B
≤ N), which is the i-th added new link connecting computer A and B.

The last test case is followed by a line containing two zeros.

Output

For each test case, print a line containing the test case number(
beginning with 1) and Q lines, the i-th of which contains a integer
indicating the number of bridges in the network after the first i new
links are added. Print a blank line after the output for each test
case.

Sample Input

3 2
1 2
2 3
2
1 2
1 3
4 4
1 2
2 1
2 3
1 4
2
1 2
3 4
0 0

Sample Output

Case 1:
1
0

Case 2:
2
0

思路

题目给出一个无向图,然后要往无向图中加边,一共加q次,每次都询问加了这条边后,图中有多少个桥。

先求出该无向图的桥的数目count和边双连通分量,缩点,每次加边(u,v),判断若u,v属于同一个双连通分量,则桥的数目不变,否则,桥的数目必定会减少,这时桥减少的数目明显和最近公共祖先lca有关,用裸的lca就行了,每次u和v向父节点回退,如果该节点是桥的端点,则cnt–,直到u==v为止。
有个优化:其实不用缩点,只要在求出桥的时候标记一下,然后在用lca求减少桥的数目时,利用dfn[]就行了,因为u,v的最近公共祖先dfn[]一定相等。

代码

#include <cstdio>
#include <cstring>
#include <cctype>
#include <stdlib.h>
#include <string>
#include <map>
#include <iostream>
#include <stack>
#include <cmath>
#include <queue>
#include <vector>
#include <algorithm>
using namespace std;
typedef long long ll;
#define inf 1000000
#define mem(a,b) memset(a,b,sizeof(a))
const int N=100000+7;
const int M=400000+5;
int dfn[N],low[N],tot,times;
int first[N],pre[N];
int bridge[N],cnt;
int n,m,k,q=1;
struct edge
{
    int v,next;
} e[M];
void add_edge(int u,int v)
{
    e[tot].v=v;
    e[tot].next=first[u];
    first[u]=tot++;
}
void init()
{
    mem(first,-1);
    mem(dfn,0);
    mem(low,0);
    mem(bridge,0);
    mem(pre,0);
    tot=0;
    cnt=0;
    times=0;
}
void tarjan(int u,int fa)
{
    low[u]=dfn[u]=++times;
    int flag=0;
    for(int i=first[u]; ~i; i=e[i].next)
    {
        int v=e[i].v;
        if(v==fa&&!flag)
        {
            flag=1;
            continue;
        }
        if(!dfn[v])
        {
            pre[v]=u;
            tarjan(v,u);
            low[u]=min(low[u],low[v]);
            if(low[v]>dfn[u])
            {
                cnt++;
                bridge[v]=1;
            }
        }
        else
            low[u]=min(low[u],dfn[v]);
    }
}

void lca(int u,int v)
{
    while(dfn[u]>dfn[v])
    {
        if(bridge[u])
        {
            cnt--;
            bridge[u]=0;
        }
        u=pre[u];
    }
    while(dfn[v]>dfn[u])
    {
        if(bridge[v])
        {
            cnt--;
            bridge[v]=0;
        }
        v=pre[v];
    }
    while(u!=v)
    {
        if(bridge[u])
        {
            cnt--;
            bridge[u]=0;
        }
        if(bridge[v])
        {
            cnt--;
            bridge[v]=0;
        }
        u=pre[u];
        v=pre[v];
    }
}

int main()
{
    int u,v;
    while(scanf("%d%d",&n,&m)&&(n||m))
    {
        init();
        for(int i=1; i<=m; i++)
        {
            scanf("%d%d",&u,&v);
            add_edge(u,v);
            add_edge(v,u);
        }
        for(int i=1; i<=n; i++)
            if(!dfn[i])
                tarjan(i,-1);
        printf("Case %d:\n",q++);
        scanf("%d",&k);
        while(k--)
        {
            scanf("%d%d",&u,&v);
            lca(u,v);
            printf("%d\n",cnt);
        }
        puts("");
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值