hdu1021 推理规律

Fibonacci Again

[url]http://acm.hdu.edu.cn/showproblem.php?pid=1021[/url]

Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

Output
Print the word "yes" if 3 divide evenly into F(n).
Print the word "no" if not.

Sample Input
0
1
2
3
4
5

Sample Output
no
no
yes
no
no
no

解题思路
同余四则运算
(a mod m) + (b mod m) 和 (a + b) mod m 是同余的。
由于没有同余符号,所以这样也可以表示:
((a mod m) + (b mod m)) mod m = (a + b) mod m

观察前两项,mod 3的余数分别是1和2,则项数和余数的对应关系为:
index mod
0 1
1 2
2 0 1 + 2 = 3...0
3 2 2 + 0 = 2
4 2 0 + 2 = 2
5 1 2 + 2 = 4...1
6 0 2 + 1 = 3...0
7 1 1 + 0 = 1
8 1 0 + 1 = 1
9 2 1 + 1 = 2
10 0 1 + 2 = 3...0
11 2 2 + 0 = 2
12 2 0 + 2 = 2
13 1 2 + 2 = 4...1
14 0 2 + 1 = 3...0

很明显,从第二个开始,每4个一循环。
公式:index mod 4 = 2


#include <stdio.h>
#include <stdlib.h>

int main (int argc, char const* argv[])
{
int n;

while (scanf("%d", &n) != EOF) {
if (n % 4 == 2) {
printf("yes\n");
} else {
printf("no\n");
}
}

return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值