hdu 1021 Fibonacci Again

Description

There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

Input

Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

Output

Print the word “yes” if 3 divide evenly into F(n).

Print the word “no” if not.

Sample Input

0
1
2
3
4
5

Sample Output

no
no
yes
no
no
no

fibonacci一般判断yes,no的时候要注意一下是否可以找规律就行。

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

int main()
{
    int a[8];
    a[0] = 1;
    a[1] = 2;
    a[2] = 0;
    a[3] = 2;
    a[4] = 2;
    a[5] = 1;
    a[6] = 0;
    a[7] = 1;
    int n;
    while(cin>>n)
    {
        if(a[n%8]==0)
            printf("yes\n");
        else
            printf("no\n");
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值