sicily 题目之 1154 1200 1324

1154. Easy sort
 
 
Total: 6575Accepted:1998Rating:
2.7/5.0(67 votes)
 

   
 
Time Limit: 1s Memory Limit: 32MB
Description

You know sorting is very important. And this easy problem is:

Given you an array with N non-negative integers which are smaller than 10,000,000, you have to sort this array. Sorting means that integer with smaller value presents first.

Input

The first line of the input is a positive integer T. T is the number of the test cases followed.

The first line of each test case is a positive integer N (1<= N<= 1000) which represents the number of integers in the array. After that, N lines followed. The i-th line is the i-th integer in the array.

Output
The output of each test case should consist of N lines. The i-th line is the i-th integer of the array after sorting. No redundant spaces are needed.
Sample Input
Copy sample input to clipboard
2
3
1
2
3
1
1
Sample Output
1
2
3
1

#include<stdio.h>
int main()
{
int cou,n,i,j,k,num[1000]={0},temp;
scanf("%d",&cou);
for(i=0;i<cou;i++)
{
scanf("%d",&n);
for(j=0;j<n;j++)
scanf("%d",&num[j]);
for(j=0;j<n;j++)
for(k=j;k<n-1;k++)
if(num[j]>num[k+1])
{temp=num[k+1];
num[k+1]=num[j];
num[j]=temp;
}
for(j=0;j<n;j++)
printf("%d/n",num[j]);
for(j=0;j<n;j++)
num[j]=0;

}
}

1200. Stick
 
 
Total: 2912Accepted:1346Rating:
1.7/5.0(15 votes)
 

   
 
Time Limit: 1s Memory Limit: 32MB
Description

Anthony has collected a large amount of sticks for manufacturing chopsticks. In order to simplify his job, he wants to fetch two equal-length sticks for machining at a time. After checking it over, Anthony finds that it is always possible that only one stick is left at last, because of the odd number of sticks and some other unknown reasons. For example, Anthony may have three sticks with length 1, 2, and 1 respectively. He fetches the first and the third for machining, and leaves the second one at last. You task is to report the length of the last stick.

Input

The input file will consist of several cases.

Each case will be presented by an integer n (1<=n<=100, and n is odd) at first. Following that, n positive integers will be given, one in a line. These numbers indicate the length of the sticks collected by Anthony.

The input is ended by n=0.

Output

For each case, output an integer in a line, which is the length of the last stick.

Sample Input
Copy sample input to clipboard
3
1
2
1
0
Sample Output
2

#include<stdio.h>
int main()
{
int i,j,n;
int a[100]={0};
while(1)
{scanf("%d",&n);

if(n%2==0||n<1||n>100)
break;
else
{
for(i=0;i<n;i++)
scanf("%d",&a[i]);

 

for(i=0;i<n-1;i++)
for(j=i;j<n-1;j++)
if(a[i]==a[j+1])
{a[i]=0;a[j+1]=0;}
for(i=0;i<n;i++)
if(a[i]!=0)
printf("%d/n",a[i]);

}
}
}

1324. Score
 
 
Total: 1865Accepted:1094Rating:
2.9/5.0(7 votes)
 

   
 
Time Limit: 1s Memory Limit: 32MB
Description

There is an objective test result such as ``OOXXOXXOOO". An `O' means a correct answer of a problem and an `X' means a wrong answer. The score of each problem of this test is calculated by itself and its just previous consecutive `O's only when the answer is correct. For example, the score of the 10th problem is 3 that is obtained by itself and its two previous consecutive `O's.

Therefore, the score of ``OOXXOXXOOO" is 10 which is calculated by ``1+2+0+0+1+0+0+1+2+3".

You are to write a program calculating the scores of test results.

Input

Your program is to read from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case starts with a line containing a string composed by `O' and `X' and the length of the string is more than 0 and less than 80. There is no spaces between `O' and `X'.

Output

Your program is to write to standard output. Print exactly one line for each test case. The line is to contain the score of the test case.

The following shows sample input and output for five test cases.

Sample Input
Copy sample input to clipboard
5 
OOXXOXXOOO 
OOXXOOXXOO 
OXOXOXOXOXOXOX 
OOOOOOOOOO 
OOOOXOOOOXOOOOX
Sample Output
10 
9 
7 
55 
30
#include<stdio.h>
int main()
{
int n[100]={0},counter=0,bou,i,j,k;
char c[81];
scanf("%d",&bou);
while(1)
{
if(counter>=bou)
break;
counter++;
scanf("%s",c);
for(i=0,j=0;c[i]!='/0';i++,j++)
{
k=i;
while(c[i]=='O'&&i>=0)
{
n[j]++;
i--;
}
i=k;
}

for(i=0,k=0;i<j;i++)
k=k+n[i];

printf("%d/n",k);
for(i=0;i<100;i++)
n[i]=0;

}
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值