10314 The Least Distance(Scau11校赛)

描述

Mr. Jeff likes swimming. But in the swimming pool he always swims from a corner to the counter corner in the way as the figure shows, i.e. he swims to the other side and back, then go to the other side corner.
 
The problem is coming: what is the least distance Mr. Jeff has to swim?


输入格式

There are several test cases, each case occupies one line. For each line, there are two positive integers, the length and width of the swimming pool. The length and width are between 1 and 9999, inclusively. Input is ended with length and width equal 0.

输出格式

Output each least distance in a single line, round the result to the float that has one bit decimal, e.g. 1.33 rounds to 1.3, 1.85 rounds to 1.9, 123.456 rounds to 123.5..

输入样例

1 1 1 2 2 1 0 0

输出样例

3.2 6.1 3.6 

题目大意

一个长方形游泳池,从左上顶点出发,左右折返三次,最后到达右下顶点,求最短路径。小数点后保留1位小数。
 
 
 
 
 
#include<stdio.h>
#include<stdlib.h>
#include<math.h>

int main()
{
    int length,width;
    float a;
    
    do
    {
          scanf("%d%d",&length,&width);
          if(length==0&&width==0)
              break;
    a=sqrt(pow(length,2)+pow(3*width,2));
    printf("%.1f\n",a);
}while(1);
    system("pause");
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值