Myeclipse Java compiler level does not match the version of the installed Java project face

升级到myeclipse 9.0之后  导入工程包 有一个 Java compiler level does not match the version of the installed Java project face 一开始没在意 因为用tomcat 部署工程也可以使用 但是由于后来要换weblogic 发现部署之后不能使用 然后在网上找了相关文章  然后从网上得出结论,在工程包属性中修改一个叫“Project Facets”的东西 OK, 果断开动  OMG。。。发现Myeclipse没有这个选项  让我情何以堪 后来只好抱着死马当活马医的心态, 打开工程的配置文件一个个看了,最后在工程目录/.settings/org.eclipse.wst.common.project.facet.core.xml中找到了一个关于facet的配置项, 把<installed facet="java" version="1.x"/>的version修改得与你的编译器版本一致, 保存刷新工程即可。
阅读更多
个人分类: Tool[开发工具]
上一篇以双斜杠//开头的URL的含义
下一篇js中判断变量类型函数typeof的用法总结
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

关闭
关闭