PAT A1133

Given a singly linked list, you are supposed to rearrange its elements so that all the negative values appear before all of the non-negatives, and all the values in [0, K] appear before all those greater than K. The order of the elements inside each class must not be changed. For example, given the list being 18→7→-4→0→5→-6→10→11→-2 and K being 10, you must output -4→-6→-2→7→0→5→10→18→11.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤105) which is the total number of nodes, and a positive K (≤103). The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer in [−105,105], and Next is the position of the next node. It is guaranteed that the list is not empty.

Output Specification:

For each case, output in order (from beginning to the end of the list) the resulting linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 9 10
23333 10 27777
00000 0 99999
00100 18 12309
68237 -6 23333
33218 -4 00000
48652 -2 -1
99999 5 68237
27777 11 48652
12309 7 33218

Sample Output:

33218 -4 68237
68237 -6 48652
48652 -2 12309
12309 7 00000
00000 0 99999
99999 5 23333
23333 10 00100
00100 18 27777
27777 11 -1

总的来说就是给你一串链表的起始节点,节点数以及分割的值,将这一串链表分成三部分:小于零,大于等于零且小于等于分割值,大于分割值,并按照原链表输入顺序进行输出。链表结尾为-1

代码如下:

#include<cstdio>
#include<iostream>
#include<vector>
using namespace std;

struct node
{
    int address;
    int date;
    int next;
}n[100010];
int N,first,K;
int cou=0;
vector<node> link;

void show(int i)
{
    if(cou==link.size()) return ;
    if(cou==0)           //第一次输出不需要输出上一个节点的地址
    {
        printf("%05d %d",link[i].address,link[i].date);
        cou++;
    }
    else if(cou==link.size()-1)
    {
        printf(" %05d\n",link[i].address);
        printf("%05d %d -1",link[i].address,link[i].date);
        cou++;
    }
    else
    {
        printf(" %05d\n",link[i].address);
        printf("%05d %d",link[i].address,link[i].date);
        cou++;
    }
}

int main()
{
    cin>>first>>N>>K;
    for(int i=0;i<N;i++)
    {
        int temp;
        cin>>temp;
        n[temp].address=temp;
        cin>>n[temp].date>>n[temp].next;
    }
    while(first!=-1)
    {
        link.push_back(n[first]);
        first=n[first].next;
    }
    for(int i=0;i<link.size();i++)
    {
        if(link[i].date<0)
            show(i);
    }

    for(int i=0;i<link.size();i++)
    {
        if(link[i].date>=0&&link[i].date<=K)
        {
            show(i);
        }

    }
    for(int i=0;i<link.size();i++)
    {
        if(link[i].date>K)
        {
            show(i);
        }
    }
    if(N==1) cout<<" -1"<<endl;
    return 0;
}

注意:倒数第二个测试点会出现不存在于链表中的节点,所以对于计数不能直接用N,而应该用林link.size()!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值