POJ P1151 Atlantis 这本是一道线段树加扫描线的板题~~

2 篇文章 0 订阅
2 篇文章 0 订阅

Atlantis
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 17656 Accepted: 6717

Description

There are several ancient Greek texts that contain descriptions of the fabled island Atlantis. Some of these texts even include maps of parts of the island. But unfortunately, these maps describe different regions of Atlantis. Your friend Bill has to know the total area for which maps exist. You (unwisely) volunteered to write a program that calculates this quantity.

Input

The input consists of several test cases. Each test case starts with a line containing a single integer n (1 <= n <= 100) of available maps. The n following lines describe one map each. Each of these lines contains four numbers x1;y1;x2;y2 (0 <= x1 < x2 <= 100000;0 <= y1 < y2 <= 100000), not necessarily integers. The values (x1; y1) and (x2;y2) are the coordinates of the top-left resp. bottom-right corner of the mapped area. 
The input file is terminated by a line containing a single 0. Don't process it.

Output

For each test case, your program should output one section. The first line of each section must be "Test case #k", where k is the number of the test case (starting with 1). The second one must be "Total explored area: a", where a is the total explored area (i.e. the area of the union of all rectangles in this test case), printed exact to two digits to the right of the decimal point. 
Output a blank line after each test case.

Sample Input

2
10 10 20 20
15 15 25 25.5
0

Sample Output

Test case #1
Total explored area: 180.00 

Source



本来是一道扫描线的板题,我在做这题时没搞懂扫描线,所以一直在想四分树可不可能做出这题,但是四分树能做的事情太多了,做这题一定是大材小用,故我想到了二维树状数组,我的上一篇博文中讲到,二维树状数组可以做的事情,单点修改加区间查询,或者区间修改加单点查询,这题就属于区间修改加单点查询,它查询只要每个点都查询一遍,修改就是之前图形的不断覆盖,配合容斥定理轻松搞定这题,不过记得加上离散化。


代码:

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<ctime>
#include<string>
#include<cstring>
#include<algorithm>
#include<fstream>
#include<queue>
#include<stack> 
#include<vector>
#include<cmath>
#include<map>
#include<iomanip>
#define rep(i,n) for(i=1;i<=n;i++)
#define MM(a,t) memset(a,t,sizeof(a))
#define lowbit(a) a&(-a)
#define INF 1e9
typedef long long ll;
#define mod 1000000007
using namespace std;
int n,xyn[2]; 
struct node{
	double x1,y1,x2,y2;
}a[120];
double xyv[2][220]; 
map<double,int> ha[2];
int bita[220][220];
void update(int x,int y,int num){
  int i,j;
  
  for(i=x;i>0;i-=lowbit(i))
    for(j=y;j>0;j-=lowbit(j))
      bita[i][j]+=num;
  
}
int query(int x,int y){
	int i,j,res=0;
	
	for(i=x;i<=xyn[0];i+=lowbit(i))
	  for(j=y;j<=xyn[1];j+=lowbit(j)){
          res=res+bita[i][j];
  	    }
   
   return res;
}
void pushin(int xy,double v){
	if(ha[xy][v]==0 && v!=0){
	  xyv[xy][++xyn[xy]]=v;
	  ha[xy][v]=1;
	}
}
double cal(int xi,int yi){
  double x1=xyv[0][xi]*1.0-xyv[0][xi-1],y1=xyv[1][yi]*1.0-xyv[1][yi-1];
  return x1*y1;	
}
int main()
{
	int i,j,n2=0;

    while(scanf("%d",&n)!=EOF){
   	   if(n==0) break;
       ha[0].clear(); ha[1].clear(); 	
       xyn[0]=0; xyn[1]=0;
       xyv[0][0]=0; xyv[1][0]=0;
       rep(i,n){
       	 double x1,y1,x2,y2;
       	 scanf("%lf%lf%lf%lf",&x1,&y1,&x2,&y2);
       	 a[i].x1=x1; a[i].x2=x2;
       	 a[i].y1=y1; a[i].y2=y2;
       	 pushin(0,x1); pushin(0,x2);
       	 pushin(1,y1); pushin(1,y2);
       }
       sort(xyv[0]+1,xyv[0]+1+xyn[0]);
       rep(i,xyn[0]) ha[0][xyv[0][i]]=i;
       sort(xyv[1]+1,xyv[1]+1+xyn[1]);
       rep(i,xyn[1]) ha[1][xyv[1][i]]=i;
       MM(bita,0);
       rep(i,n){
       	 int x1=ha[0][a[i].x1],y1=ha[1][a[i].y1],x2=ha[0][a[i].x2],y2=ha[1][a[i].y2];
		 update(x1,y1,1); update(x2,y2,1);
		 update(x1,y2,-1); update(x2,y1,-1);
       }
       double res=0.0;
       rep(i,xyn[0])
         rep(j,xyn[1])
           if(query(i,j)){
           	 res+=cal(i,j);
           }
       printf("Test case #%d\n",++n2);
       printf("Total explored area: %.2lf\n",res);
       cout<<'\n';
    }
	
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值