C - Oil Deposits(dfs)

点击打开链接


Oil Deposits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 21383    Accepted Submission(s): 12319


Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 
 

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
 

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
 

Sample Input
    
    
1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0
 

Sample Output
    
    
0 1 2 2

 
 
  
  
Select Code
#include <stdio.h>
#include <iostream>
using namespace std;

char s[102][102];
int m,n;
int i,j;

void dfs(int x,int y)
{
	if(x<1||x>m||y<1||y>n)
	return ;					// 函数返回值为空
	if(s[x][y]!='@')
	return ;
	s[x][y]='*';				//标记 
	for(int i=-1 ; i<=1 ; i++)
		for(int j=-1 ; j<=1 ; j++) 		//八个方向				{				//也有另外一种写法  即用数组表示b[8][2]={{-1,0},{1,0},{0,-1},{0,1}
			dfs(x+i,y+j);		//     ,{-1,1},{-1,-1},{1,1},{1,-1}}
		}
}
int main()
{
	while(cin>>m>>n&&m&&n)				//这个地方的输入格式用这种,不用scanf
	{
		int c=0;
		for(i=1 ; i<=m ; ++i)
			for(j=1 ; j<=n ; j++)
			{
				cin>>s[i][j];
			}
			for(i=1 ; i<=m ; ++i)
				 for(j=1 ; j<=n ; ++j)
				 {
				 	if(s[i][j]=='@')
				 	{
				 		dfs(i,j);
				 		c++;
					 }
				 }
				cout<<c<<endl;				// return 0 ?
	}
	
	
}
    
    

 
 



这个题可以作为dfs的一个模板,通过这道题自己更加理解了dfs;




DFS + BFS // 深搜 || 广搜
http://blog.csdn.net/WYK1823376647/article/details/76376736


http://blog.csdn.net/WYK1823376647/article/details/76377050


http://blog.csdn.net/wyk1823376647/article/details/52062965


http://blog.csdn.net/wyk1823376647/article/details/52200485


http://blog.csdn.net/wyk1823376647/article/details/52739349


http://blog.csdn.net/wyk1823376647/article/details/52734432


http://blog.csdn.net/wyk1823376647/article/details/69214947


http://blog.csdn.net/wyk1823376647/article/details/52200580




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值