【日常练习 01背包】HDU 2602 Bone Collector

Bone Collector

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 50088 Accepted Submission(s): 21002


Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
这里写图片描述


Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.


Output
One integer per line representing the maximum of the total value (this number will be less than 231).


SampleInput

1
5 10
1 2 3 4 5
5 4 3 2 1


SampleOutput

14


题意
大致就是给两个数n,v;分别表示骨头的个数和体积的最大承载,接下来第一排是骨头的价值,第二排是给出骨头的体积


按照价值反着背包;

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
struct Bone{
    int value;
    int volume;
}b[1010];

int maxi(int x,int y){
    return x>y?x:y;
}

int ans[1010];

int main(){
    int t;
    cin>>t;
    int n,v;
    while(t--){
        scanf("%d%d",&n,&v);
        for(int i=0;i<n;i++){
            cin>>b[i].value;
        }
        for(int i=0;i<n;i++){
            cin>>b[i].volume;
        }
        memset(ans,0,sizeof(ans));
        for(int i=0;i<n;i++){
            for(int j=v;j>=b[i].volume;j--){
                ans[j] = maxi(ans[j],ans[j-b[i].volume]+b[i].value);
            }
        }
        cout<<ans[v]<<endl;
    }return 0;
}

偷偷附一个链接嘻嘻嘻 http://blog.csdn.net/lois_123/article/details/38232967有一维和二维数组两种做法;
再偷偷附一个背包九讲 :http://love-oriented.com/pack/

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值