android studio 3.1 混淆编译出现提示 please correct the above warnings first

昨天编译包的时候出现了问题,出现了以下错误信息,并且左边的错误信息也是编译器的错误信息,无法定位到具体错误位置,但是我并没有更改过依赖包和混淆文件,之前是确信可以混淆编译的,突然就不行了,查了半天非常绝望;测试编译没问题,混淆编译就会出错;

后来我升级了下BuildTool等sdk文件,后来检查发现 gradle里面我有配置

lintOptions {
    abortOnError false
}

这个导致了我在message下看不到具体的错误信息,然后我屏蔽这句后重新编译,提示了aapt2相关的错误信息;

按照网上的提示 我在gradle.properties下增加了以下语句:

android.enableAapt2=false

然后编译,获取到了编译错误的具体原因,最后查到的原因是因为我在某一个类里面有两个子类名称只有大小写不一样,导致混淆编译的时候报错,但是不混淆编译就不会出错,加上当时我屏蔽了错误信息,找不到错误位置,导致我弄了一下午!

最终 我修改了其中一个类的名字,再次编译就成功了!

特此记录一下,不知道能不能帮到别人,但是留着给自己提个醒;




阅读更多
文章标签: android androidstudio
个人分类: android
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

关闭
关闭
关闭