http://poj.org/problem?id=3009
Curling 2.0
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 19525 Accepted: 7971
Description
On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.
Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.
Fig. 1: Example of board (S: start, G: goal)
The movement of the stone obeys the following rules:
At the beginning, the stone stands still at the start square.
The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
Once thrown, the stone keeps moving to the same direction until one of the following occurs:
The stone hits a block (Fig. 2(b), (c)).
The stone stops at the square next to the block it hit.
The block disappears.
The stone gets out of the board.
The game ends in failure.
The stone reaches the goal square.
The stone stops there and the game ends in success.
You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.
Fig. 2: Stone movements
Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.
With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).
Fig. 3: The solution for Fig. D-1 and the final board configuration
Input
The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.
Each dataset is formatted as follows.
the width(=w) and the height(=h) of the board
First row of the board
…
h-th row of the board
The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.
Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.
0 vacant square
1 block
2 start position
3 goal position
The dataset for Fig. D-1 is as follows:
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
Output
For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.
Sample Input
2 1
3 2
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
6 1
1 1 2 1 1 3
6 1
1 0 2 1 1 3
12 1
2 0 1 1 1 1 1 1 1 1 1 3
13 1
2 0 1 1 1 1 1 1 1 1 1 1 3
0 0
Sample Output
1
4
-1
4
10
-1
这道题题意真tm长,但是居然读完了,也摸索出个好点读题技巧(自认为,还是弱…):
半中文半英文对着读(用谷歌网页翻译不停切换…)
分析
dfs,向4个方向搜索,直到碰到1或者出界
time:110ms
#include<iostream>
#include<string.h>
using namespace std;
#define N 25
#define inf 1000000
int g[N][N];
int dire[4][2]={{0,1},{0,-1},{-1,0},{1,0}};
int tot=inf;
int n,m;
int sx,sy;
inline int inside(int x,int y){
return (x>=1&&x<=n&&y>=1&&y<=m);
}
void dfs(int x,int y,int step){
if(step>9 || step>tot)
return;
for(int i=0;i<4;i++){
int px=x,py=y;
//判断方向是否能前进
if(g[x+dire[i][0]][y+dire[i][1]]==1)
continue;
while(inside(px,py)){
px+=dire[i][0],py+=dire[i][1];
if(g[px][py]==3){
tot=min(tot,step+1);
return;
}
if(g[px][py]==1)
break;
}
if(g[px][py]==1){
g[px][py]=0;
dfs(px-dire[i][0],py-dire[i][1],step+1);
g[px][py]=1;
}
}
}
int main(){
//freopen("in.txt","r",stdin);
std::ios_base::sync_with_stdio(false);
while(cin>>m>>n){
if(!m &&!n) break;
memset(g,0,sizeof(g));//tm 没加这行错N次,但还是不懂这行有什么用,感觉不需要初始化...
for(int i=1;i<=n;i++){
for(int j=1;j<=m;j++){
cin>>g[i][j];
if(g[i][j]==2) sx=i,sy=j;
}
}
tot=inf;
dfs(sx,sy,0);
if(tot <=10)
cout<<tot<<endl;
else
cout<<-1<<endl;
}
return 0;
}
但其实这个算法还可以再优化一下,将dfs部分改为如下
void dfs(int x,int y,int step){
if(step>9 || step>tot)
return;
for(int i=0;i<4;i++){
int px=x,py=y;
if(g[x+dire[i][0]][y+dire[i][1]]==1)
continue;
while(px>=1&&px<=n&&py>=1&&py<=m&&g[px][py]==0){
px+=dire[i][0],py+=dire[i][1];
}
if(px>=1&&px<=n&&py>=1&&py<=m&&g[px][py]==3){
tot=min(tot,step+1);
return;
}
if(px>=1&&px<=n&&py>=1&&py<=m&&g[px][py]==1){
g[px][py]=0;
dfs(px-dire[i][0],py-dire[i][1],step+1);
g[px][py]=1;
}
}
}
此时
time:47到79.比原来又有一些提升
分析
对比一下,发现二者差异体现在后者把判断从while中提出来了,不是在while循环中每次判断,这才是最终原因,以后写代码尽量注意.
如果time比较接近time limit(例如time limit 为1000MS),而实际只比limit高一点,可以试试修改一下判断或者其他卡过去,当然卡过去肯定不是最优解,但时间有限,能卡过就过.
体会
感觉inline int inside(int x,int y) 与 直接写(x>=1&&x<=n&&y>=1&&y<=m)几乎没什么差别,不如写inline 格式省点事儿..(可能inside多次用到)
scanf与cin 在用了std::ios_base::sync_with_stdio(false);之后差距也不是很大.(数据大的时候也才几十ms);