二叉树的遍历:数据结构实验之二叉树二:遍历二叉树

例:通过下列例子了解二叉树的遍历。

 

 

Problem Description

 

已知二叉树的一个按先序遍历输入的字符序列,如abc,,de,g,,f,,, (其中,表示空结点)。请建立二叉树并按中序和后序的方式遍历该二叉树。

Input

连续输入多组数据,每组数据输入一个长度小于50个字符的字符串。

Output

每组输入数据对应输出2行:
第1行输出中序遍历序列;
第2行输出后序遍历序列。

 

Example Input

abc,,de,g,,f,,,

Example Output

cbegdfa
cgefdba
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
char s[60];
int i;
struct node
{
    char data;
    struct node *lchild, *rchild;
};
struct node *creat()
{
    struct node *root;
    if(s[++i] == ',') //这里i++不对,++i就对了(还是百度查的,唉)
    {
        root = NULL;
    }
    else
    {
        root = (struct node *)malloc(sizeof(struct node));
        root -> data = s[i];
        root -> lchild = creat();
        root -> rchild = creat();
    }
    return root;
};
void mid(struct node *root)
{
    if(root != NULL)
    {
        mid(root -> lchild);
        printf("%c", root -> data);
        mid(root -> rchild);
    }
}
void last(struct node *root)
{
    if(root != NULL)
    {
        last(root -> lchild);
        last(root -> rchild);
        printf("%c", root -> data);
    }
}
int main()
{

    while(scanf("%s", s) != EOF)
    {
        i = -1;
        struct node *root;
        root = creat();
        mid(root);
        printf("\n");
        last(root);
        printf("\n");
    }
    return 0;
}

 

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值