数据结构实验之链表五:单链表的拆分

数据结构实验之链表五:单链表的拆分

题目描述

输入N个整数顺序建立一个单链表,将该单链表拆分成两个子链表,第一个子链表存放了所有的偶数,第二个子链表存放了所有的奇数。两个子链表中数据的相对次序与原链表一致。

输入

第一行输入整数N;;
第二行依次输入N个整数。

输出

第一行分别输出偶数链表与奇数链表的元素个数;
第二行依次输出偶数子链表的所有数据;
第三行依次输出奇数子链表的所有数据。

示例输入

10
1 3 22 8 15 999 9 44 6 1001

示例输出

4 6
22 8 44 6 
1 3 15 999 9 1001

#include<bits/stdc++.h>
using namespace std;
struct node
{
    int data;
    node *next;
}*p,*q,*head,*tail,*head1,*head2;
struct node *creat(int n);
struct node *split(struct node *head1);
void display(struct node *head);
int main()
{
    int n;
    cin>>n;
    head=creat(n);
    head1=split(head);
    display(head);
    display(head1);
    return 0;
}
struct node *creat(int n)
{
    int i;
    head=new node;
    head->next=NULL;
    for(i=0; i<n; i++)
    {
        p=new node;
        cin>>p->data;
        p->next=head->next;
        head->next=p;
    }
    return head;
}
void display(struct node *head)
{
    p=head->next;
    while(p)
    {
        if(p->next)
            cout<<p->data<<" ";
        else
            cout<<p->data<<endl;
        p=p->next;
    }
}
struct node *split(struct node *head1)
{
    int a=0,b=0;
    head2=new node;
    head2->next=NULL;
    p=head1->next;
    head1->next=NULL;
    q=p->next;
    while(p)
    {
        if(p->data%2==0)
        {
            p->next=head1->next;
            head1->next=p;
            a++;
        }
        else
        {
            p->next=head2->next;
            head2->next=p;
            b++;
        }
        p=q;
        if(q)
        {
            q=q->next;
        }
    }
    cout<<a<<" "<<b<<endl;
    return head2;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值