数据结构实验之链表六:有序链表的建立

数据结构实验之链表六:有序链表的建立

题目描述

输入N个无序的整数,建立一个有序链表,链表中的结点按照数值非降序排列,输出该有序链表。

输入

第一行输入整数个数N;
第二行输入N个无序的整数。

输出

依次输出有序链表的结点值。

示例输入

6
33 6 22 9 44 5

示例输出

5 6 9 22 33 44

<span style="background-color: rgb(255, 204, 204);"><span style="color:#FFFFFF;"><span style="background-color: rgb(204, 102, 204);">#include<bits/stdc++.h>
using namespace std;
struct node
{
    int data;
    node *next;
}*p,*q,*head,*tail,*head1,*head2;
void A(struct node *head);
void display(struct node *head);
int main()
{
    int n,i;
    head=new node;
    head->next=NULL;
    cin>>n;
    for(i=0; i<n; i++)
    {
        A(head);
    }
    display(head);
    return 0;
}
void display(struct node *head)
{
    p=head->next;
    while(p)
    {
        if(p->next)
            cout<<p->data<<" ";
        else
            cout<<p->data<<endl;
        p=p->next;
    }
}
void A(struct node *head)
{
    struct node *r;
    p=head->next;
    q=head;
    r=new node;
    cin>>r->data;
    while(p)
    {
        if(r->data<p->data)
        {
            q->next=r;
            r->next=p;
            break;
        }
        q=p;
        p=p->next;
    }
    if(!p)
    {
        q->next=r;
        r->next=NULL;
    }
}</span></span>
</span>

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值