ZJU PTA ds 7-1 File Transfer

7-1 File Transfer

We have a network of computers and a list of bi-directional connections. Each of these connections allows a file transfer from one computer to another. Is it possible to send a file from any computer on the network to any other?

Input Specification:
Each input file contains one test case. For each test case, the first line contains N ( 2 ≤ N ≤ 1 0 4 2≤N≤10^4 2N104), the total number of computers in a network. Each computer in the network is then represented by a positive integer between 1 1 1 and N N N. Then in the following lines, the input is given in the format:

I c1 c2  

where I stands for inputting a connection between c1 and c2; or

C c1 c2    

where C stands for checking if it is possible to transfer files between c1 and c2; or

S

where S stands for stopping this case.

Output Specification:

For each C case, print in one line the word “yes” or “no” if it is possible or impossible to transfer files between c1 and c2, respectively. At the end of each case, print in one line “The network is connected.” if there is a path between any pair of computers; or “There are k components.” where k is the number of connected components in this network.

Sample Input 1:

5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
S

Sample Output 1:

no
no
yes
There are 2 components.

Sample Input 2:

5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
I 1 3
C 1 5
S

Sample Output 2:

no
no
yes
yes
The network is connected.

My code

#include <stdio.h>
#include <string.h>
#include <stdlib.h>

typedef int ElementType;
typedef int SetType;

void Initialization(int *s, int n);
void SetUnion(int *s, int root1, int root2);
SetType Find(int x, int *s);

int main()
{
    int n;
    scanf("%d", &n);
    int *s = (int*)malloc(sizeof(int) * (n + 1));
    Initialization(s, n + 1);

    char tmp[2];
    scanf("%s", tmp);// one string, two numbers
	int c1, c2;
	while (strcmp(tmp, "S") != 0) {
		scanf("%d%d", &c1, &c2);
		if (strcmp(tmp, "C") == 0) {//  checking if it is possible to transfer files between c1 and c2
            if (Find(c1, s) == Find(c2, s)) {
                puts("yes");
            }
            else {
                puts("no");
            }
        }
        else if (strcmp(tmp, "I") == 0) {// inputting a connection between c1 and c2
            SetUnion(s, Find(c1, s), Find(c2, s));
        }
		scanf("%s", &tmp);
	}
	
	int cnt = 0;
	for (int i = 1; i <= n; i++) {
		if (s[i] < 0) {
			cnt++;
		}
	}
	if (cnt == 1) {
		puts("The network is connected.");
	}
	else if (cnt > 1) {
		printf("There are %d components.", cnt);
	}
    return 0;
}

void Initialization(int *s, int n)
{
   memset(s, -1, sizeof(s[0]) * n);// initialize this piece of content to -1
}


/* Code ofr disjoint set Find with path compression*/
SetType Find(int x, int *s)
{
    if (s[x] <= 0) {
        return x;
    }
    return s[x] = Find(s[x], s);
}

void SetUnion(int *s, int root1, int root2)
{
    if (root1 == root2) {
        return ;
    }
    if (s[root2] < s[root1]) {
        s[root2] = s[root2] + s[root1];
        s[root1] = root2;// 如果root2的size大小更大,那么将root1指向root2
    }
    else {
        s[root1] = s[root1] + s[root2];
        s[root2] = root1;
    }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
ZJU-I型机械臂是一种由浙江大学机器人研究所开发的六自由度机械臂,具有高速、精度和可靠性等特点。机械臂的运动控制是机器人中的重要研究领域之一,其中点到点轨迹规划是机器人在运动过程中最基础和常用的一种方式,也是机械臂控制的核心问题之一。 点到点轨迹规划的目标是通过给定的起点和终点,计算出机械臂的运动轨迹,使机械臂在运动过程中满足机械臂轨迹的连续性、平滑性、可控性等要求。在过去的研究中,经典的点到点轨迹规划方法包括插值法、线性规划法、最小能量法等。 如果使用Python实现机械臂的点到点轨迹规划,可以采用Robotics Toolkit(简称robot)这个模块。robot模块提供了各种从轨迹规划、控制到仿真的功能,可用于ROS、Vrep、Webots等机器人仿真软件。使用robot模块,可以通过几行代码实现机械臂的点到点轨迹规划,例如: ``` from roboticstoolkit import robot from roboticstoolkit.robots import zju # 初始化机器人 zju_arm = robot.Robot('zju', zju.URDF) # 设定起点和终点 start = [0, 0, 0, 0, 0, 0] goal = [0, 1, 1, 0.5, 0, 0] # 计算机械臂的轨迹 path = zju_arm.get_trajectory(start, goal) # 控制机械臂运动到终点 zju_arm.move_to(goal) ``` 其中,`roboticstoolkit`和`roboticstoolkit.robots`都是导入的Python模块,`zju`是机械臂的URDF定义文件,`start`和`goal`是起点和终点的坐标,`get_trajectory()`函数会返回计算得到的机械臂轨迹,`move_to()`函数则控制机械臂运动到终点。 总之,使用Python实现ZJU-I型机械臂的点到点轨迹规划相对简单,只需要导入相应的模块,并根据需要设置机械臂的各种参数,即可轻松实现机械臂的控制。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值