Accepted Necklace//HDU - 2660//dfs

Accepted Necklace//HDU - 2660//dfs


题目

I have N precious stones, and plan to use K of them to make a necklace for my mother, but she won’t accept a necklace which is too heavy. Given the value and the weight of each precious stone, please help me find out the most valuable necklace my mother will accept.
Input
The first line of input is the number of cases.
For each case, the first line contains two integers N (N <= 20), the total number of stones, and K (K <= N), the exact number of stones to make a necklace.
Then N lines follow, each containing two integers: a (a<=1000), representing the value of each precious stone, and b (b<=1000), its weight.
The last line of each case contains an integer W, the maximum weight my mother will accept, W <= 1000.
Output
For each case, output the highest possible value of the necklace.
Sample Input
1
2 1
1 1
1 1
3
Sample Output
1
题意
串项链,重量之内价值尽可能高
链接:http://acm.hdu.edu.cn/showproblem.php?pid=2660

思路

dfs,重量作为判断条件即可

代码

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <string>

using namespace std;
pair<int,int> neck[30];
int n,t,k,W;
int maxn=0;
void dfs(int weight,int temp,int left,int price){
    if(weight>W||temp>=n) return;
    if(left==0){
        if(price>maxn) maxn=price;
        return ;
    }
    for(int i=temp;i<n;i++){
        dfs(weight+neck[i].second,i+1,left-1,price+neck[i].first);
    }
}
int main()
{
    cin>>t;
    for(int i=0;i<t;i++){
        cin>>n>>k;
        for(int j=0;j<n;j++){
            cin>>neck[j].first>>neck[j].second;
        }
        cin>>W;
        maxn=0;
        dfs(0,0,k,0);
        cout<<maxn<<endl;
    }
    return 0;
}

注意

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值