Dice//LightOJ - 1248//概率dp

Dice//LightOJ - 1248//概率dp


题目

Given a dice with n sides, you have to find the expected number of times you have to throw that dice to see all its faces at least once. Assume that the dice is fair, that means when you throw the dice, the probability of occurring any face is equal.
For example, for a fair two sided coin, the result is 3. Because when you first throw the coin, you will definitely see a new face. If you throw the coin again, the chance of getting the opposite side is 0.5, and the chance of getting the same side is 0.5. So, the result is
1 + (1 + 0.5 * (1 + 0.5 * …))
= 2 + 0.5 + 0.52 + 0.53 + …
= 2 + 1 = 3
Input
Input starts with an integer T (≤ 100), denoting the number of test cases.
Each case starts with a line containing an integer n (1 ≤ n ≤ 105).
Output
For each case, print the case number and the expected number of times you have to throw the dice to see all its faces at least once. Errors less than 10-6 will be ignored.

Sample Input
5
1
2
3
6
100
Sample Output
Case 1: 1
Case 2: 3
Case 3: 5.5
Case 4: 14.7
Case 5: 518.7377517640
题意
n面骰子,求n面都骰出来的期望
链接:https://vjudge.net/contest/349029#problem/F

思路

概率dp,公式 dp[i]=i/ndp[i]+(n-i)/ndp[i+1]+1

代码

#include <cstdio>
#include<algorithm>
#define N 30001
using namespace std;
const int inf = 0x3f3f3f3f;

double dp[100010];
int main()
{
    int t;
    scanf("%d",&t);
    int casen=1;
    while(t--)
    {
        int n;
        scanf("%d",&n);
        dp[n]=0.0;
        for(int i=n-1;i>=0;i--){
            dp[i]=dp[i+1]+(n*1.0)/((double)(n-i));
        }
        printf("Case %d: %.7lf\n",casen++,dp[0]);
    }
    return 0;
}

注意

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值