I Hate It//HDU - 1754//线段树

I Hate It//HDU - 1754//线段树


题目

很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。
这让很多学生很反感。

不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。
Input
本题目包含多组测试,请处理到文件结束。
在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表学生的数目和操作的数目。
学生ID编号分别从1编到N。
第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。
接下来有M行。每一行有一个字符 C (只取’Q’或’U’) ,和两个正整数A,B。
当C为’Q’的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。
当C为’U’的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。
Output
对于每一次询问操作,在一行里面输出最高成绩。
Sample Input
5 6
1 2 3 4 5
Q 1 5
U 3 6
Q 3 4
Q 4 5
U 2 9
Q 1 5
Sample Output
5
6
5
9
Hint
Huge input,the C function scanf() will work better than cin
链接https://vjudge.net/contest/352439#problem/D

思路

类似线段树模板,稍微改一改求最大值即可

代码

#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <stack>
#include <queue>
using namespace std;
typedef long long ll;

int num[200010];
struct node{
    int maxn,left,right;
}tree[200010*3];

int build(int root,int left,int right)        //构建线段树
{
    tree[root].left=left;
    tree[root].right=right;
    if(left==right){
        return tree[root].maxn=num[left];
    }
    int mid=left+right>>1;        //递归建立左右子树
    int a=build(root<<1,left,mid);
    int b=build(root<<1|1,mid+1,right);
    return tree[root].maxn=max(a,b);
}

int findx(int root,int left,int right)  //查找left和right之间的最大值
{
    if(tree[root].left>right||tree[root].right<left)
        return 0;
    if(left<=tree[root].left&&tree[root].right<=right)
        return tree[root].maxn;
    int a=findx(2*root,left,right);
    int b=findx(2*root+1,left,right);
    return max(a,b);
}

int update(int root,int pos,int val)  //更新pos点的值
{
    if(pos<tree[root].left||tree[root].right<pos)
        return tree[root].maxn;
    if(tree[root].left==pos&&tree[root].right==pos)
        return tree[root].maxn=val;
    int a=update(2*root,pos,val);
    int b=update(2*root+1,pos,val);
    tree[root].maxn=max(a,b);
    return tree[root].maxn;
}

int main()
{
    int n,m,x,y;
    char ch;
    while(scanf("%d%d",&n,&m)!=EOF){
        for(int i=1;i<=n;i++)
            scanf("%d",&num[i]);
        build(1,1,n);
        for(int i=1;i<=m;i++){
            getchar();
            scanf("%c%d%d",&ch,&x,&y);
            if(ch=='Q')
                printf("%d\n",findx(1,x,y));
            else{
                num[x]=y;
                update(1,x,y);
            }
        }
    }
    return 0;
}

注意

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值