Description
We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.
Figure A Sample Input of Radar Installations
Input
The input is terminated by a line containing pair of zeros
Output
Sample Input
3 2 1 2 -3 1 2 1 1 2 0 2 0 0
Sample Output
Case 1: 2 Case 2: 1
题意:用x轴表示海岸,陆地在x轴下方,海在x轴上方。每个小岛都是海中的一个点。雷达只能安装在x轴上,覆盖范围为d。问最少用多少个雷达能把所有的岛屿覆盖。
思路:先通过平面几何的知识计算出各个岛屿的雷达区间(如图),这样子我们就能得到一段段区间,接着按左端点从小到大排序,然后分情况讨论:
一、输出-1的情况: 1.d<0
2.|y|>d
3.y<0
二、讨论区间之间的关系: 1.相离:上个区间的右端点<下个区间的左端点
2.包含:上个区间的右端点>下个区间的右端点
3.相交但不包含:上个区间的右端点>下个区间的左端点
用贪心法的思想,把雷达安装在区间的最右处(右端点),这样雷达能覆盖到下个小岛的机率更高,如果是第一种相离的情况,说明雷达无法覆盖下个小岛,则要多用一个雷达;如果是第二种包含的情况,也说明雷达无法覆盖下个小岛,此时把雷达的位置改为下个区间的右端点(这样两个小岛都能覆盖到);如果是第三种相交但不包含的情况,说明雷达两个岛都能覆盖,则直接判断下个区间即可。
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
int n;
double d;
struct pos
{
double x,y;
} a[1005];
struct dis
{
double left,right;
} b[1005];
bool cmp(dis A,dis B)
{
return A.left<B.left;
}
int main()
{
int k=1;
while(scanf("%d%lf",&n,&d)&&n&&d)
{
bool flag=false;
if(d<0)
flag=true;
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
for(int i=0; i<n; i++)
{
scanf("%lf%lf",&a[i].x,&a[i].y);
if(fabs(a[i].y)>d||a[i].y<0)
flag=true;
double tmp=sqrt(d*d-a[i].y*a[i].y);
b[i].left=a[i].x-tmp;
b[i].right=a[i].x+tmp;
}
if(flag)
{
printf("Case %d: -1\n",k++);
continue;
}
sort(b,b+n,cmp);
int cnt=1,i=1;
double radar=b[0].right;
while(i<n)
{
if(b[i].left>radar) //相离
{
cnt++;
radar=b[i].right;
}
/*else if(b[i].left<radar&&b[i].right>radar) //相交不包含
{
}*/
else if(b[i].left<radar&&b[i].right<radar) //包含
{
radar=b[i].right;
}
i++;
}
printf("Case %d: %d\n",k++,cnt);
}
}