Falling Leaves
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 4638 | Accepted: 2535 |
Description
Figure 1
Figure 1 shows a graphical representation of a binary tree of letters. People familiar with binary trees can skip over the definitions of a binary tree of letters, leaves of a binary tree, and a binary search tree of letters, and go right to The problem.
A binary tree of letters may be one of two things:
- It may be empty.
- It may have a root node. A node has a letter as data and refers to a left and a right subtree. The left and right subtrees are also binary trees of letters.
In the graphical representation of a binary tree of letters:
- Empty trees are omitted completely.
- Each node is indicated by
- Its letter data,
- A line segment down to the left to the left subtree, if the left subtree is nonempty,
- A line segment down to the right to the right subtree, if the right subtree is nonempty.
- Its letter data,
A leaf in a binary tree is a node whose subtrees are both empty. In the example in Figure 1, this would be the five nodes with data B, D, H, P, and Y.
The preorder traversal of a tree of letters satisfies the defining properties:
- If the tree is empty, then the preorder traversal is empty.
- If the tree is not empty, then the preorder traversal consists of the following, in order
- The data from the root node,
- The preorder traversal of the root's left subtree,
- The preorder traversal of the root's right subtree.
- The data from the root node,
The preorder traversal of the tree in Figure 1 is KGCBDHQMPY.
A tree like the one in Figure 1 is also a binary search tree of letters. A binary search tree of letters is a binary tree of letters in which each node satisfies:
The root's data comes later in the alphabet than all the data in the nodes in the left subtree.
The root's data comes earlier in the alphabet than all the data in the nodes in the right subtree.
The problem:
Consider the following sequence of operations on a binary search tree of letters
Remove the leaves and list the data removed
Repeat this procedure until the tree is empty
Starting from the tree below on the left, we produce the sequence of trees shown, and then the empty tree
by removing the leaves with data
BDHPY
CM
GQ
K
Your problem is to start with such a sequence of lines of leaves from a binary search tree of letters and output the preorder traversal of the tree.
Input
The input will contain one or more data sets. Each data set is a sequence of one or more lines of capital letters.
The lines contain the leaves removed from a binary search tree in the stages described above. The letters on a line will be listed in increasing alphabetical order. Data sets are separated by a line containing only an asterisk ('*').
The last data set is followed by a line containing only a dollar sign ('$'). There are no blanks or empty lines in the input.
The lines contain the leaves removed from a binary search tree in the stages described above. The letters on a line will be listed in increasing alphabetical order. Data sets are separated by a line containing only an asterisk ('*').
The last data set is followed by a line containing only a dollar sign ('$'). There are no blanks or empty lines in the input.
Output
For each input data set, there is a unique binary search tree that would produce the sequence of leaves. The output is a line containing only the preorder traversal of that tree, with no blanks.
Sample Input
BDHPY CM GQ K * AC B $
Sample Output
KGCBDHQMPY BAC
题意:
给定一棵二叉搜索树以及相关的一系列操作:
(1) 删除叶子结点并给出删除的数据;
(2) 重复此过程,直至二叉树为空。
从左下角的叶子结点开始进行上述操作,得到一系列该二叉树的结点序列。根据给出的这几行树结点序列(树与树之间以“*”为间隔,输入结束标志为“$”),求该二叉树先序遍历的结点序列。
思路:根据给出的几行结点序列,先建树,然后再进行先序遍历。
#include<cstdio>
#include<cstring>
#define N 10000
using namespace std;
char a[N][N];
char tmp[N];
typedef struct BTnode
{
char x;
BTnode *lchild,*rchild;
BTnode(char c)
{
x=c;
lchild=rchild=NULL;
}
BTnode()
{
lchild=rchild=NULL;
}
} BTnode;
void preorder(BTnode *t)
{
if(t)
{
printf("%c",t->x);
preorder(t->lchild);
preorder(t->rchild);
}
}
int main()
{
int i=0;
while(scanf("%s",tmp)!=EOF)
{
if(strcmp(tmp,"*")!=0&&strcmp(tmp,"$")!=0)
{
strcpy(a[i++],tmp);
}
if(strcmp(tmp,"*")==0||strcmp(tmp,"$")==0)
{
int n=i;
i=0;
BTnode *root=new BTnode(a[n-1][0]);
for(int j=n-2; j>=0; j--)
{
for(int k=0; k<strlen(a[j]); k++)
{
BTnode *p=root,*q=NULL;
while(p)
{
q=p;
if(a[j][k]<p->x)
p=p->lchild;
else if(a[j][k]>p->x)
p=p->rchild;
}
p=new BTnode(a[j][k]);
if(a[j][k]<q->x)
q->lchild=p;
else
q->rchild=p;
}
}
preorder(root);
printf("\n");
if(strcmp(tmp,"$")==0)
break;
}
}
}