Crashing Robots
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 10531 | Accepted: 4465 |
Description
In a modernized warehouse, robots are used to fetch the goods. Careful planning is needed to ensure that the robots reach their destinations without crashing into each other. Of course, all warehouses are rectangular, and all robots occupy a circular floor space with a diameter of 1 meter. Assume there are N robots, numbered from 1 through N. You will get to know the position and orientation of each robot, and all the instructions, which are carefully (and mindlessly) followed by the robots. Instructions are processed in the order they come. No two robots move simultaneously; a robot always completes its move before the next one starts moving.
A robot crashes with a wall if it attempts to move outside the area of the warehouse, and two robots crash with each other if they ever try to occupy the same spot.
A robot crashes with a wall if it attempts to move outside the area of the warehouse, and two robots crash with each other if they ever try to occupy the same spot.
Input
The first line of input is K, the number of test cases. Each test case starts with one line consisting of two integers, 1 <= A, B <= 100, giving the size of the warehouse in meters. A is the length in the EW-direction, and B in the NS-direction.
The second line contains two integers, 1 <= N, M <= 100, denoting the numbers of robots and instructions respectively.
Then follow N lines with two integers, 1 <= Xi <= A, 1 <= Yi <= B and one letter (N, S, E or W), giving the starting position and direction of each robot, in order from 1 through N. No two robots start at the same position.
Figure 1: The starting positions of the robots in the sample warehouse
Finally there are M lines, giving the instructions in sequential order.
An instruction has the following format:
< robot #> < action> < repeat>
Where is one of
and 1 <= < repeat> <= 100 is the number of times the robot should perform this single move.
The second line contains two integers, 1 <= N, M <= 100, denoting the numbers of robots and instructions respectively.
Then follow N lines with two integers, 1 <= Xi <= A, 1 <= Yi <= B and one letter (N, S, E or W), giving the starting position and direction of each robot, in order from 1 through N. No two robots start at the same position.
Figure 1: The starting positions of the robots in the sample warehouse
Finally there are M lines, giving the instructions in sequential order.
An instruction has the following format:
< robot #> < action> < repeat>
Where is one of
- L: turn left 90 degrees,
- R: turn right 90 degrees, or
- F: move forward one meter,
and 1 <= < repeat> <= 100 is the number of times the robot should perform this single move.
Output
Output one line for each test case:
Only the first crash is to be reported.
- Robot i crashes into the wall, if robot i crashes into a wall. (A robot crashes into a wall if Xi = 0, Xi = A + 1, Yi = 0 or Yi = B + 1.)
- Robot i crashes into robot j, if robots i and j crash, and i is the moving robot.
- OK, if no crashing occurs.
Only the first crash is to be reported.
Sample Input
4 5 4 2 2 1 1 E 5 4 W 1 F 7 2 F 7 5 4 2 4 1 1 E 5 4 W 1 F 3 2 F 1 1 L 1 1 F 3 5 4 2 2 1 1 E 5 4 W 1 L 96 1 F 2 5 4 2 3 1 1 E 5 4 W 1 F 4 1 L 1 1 F 20
Sample Output
Robot 1 crashes into the wall Robot 1 crashes into robot 2 OK Robot 1 crashes into robot 2
分析:数据都在100以内,直接暴力模拟即可。需要注意的是看准图的标号方向。
#include<cstdio>
using namespace std;
struct robot
{
int x,y;//坐标
char dir;//方向
} r[105];
int n,m;
int a,b;
int judge(int num,int x,int y)
{
if(x<=0||x>=a+1||y<=0||y>=b+1)
return -1;//撞墙了就返回-1
else
{
for(int i=1; i<=n; i++)
{
if(i!=num)
if(r[i].x==x&&r[i].y==y)
return i;//与其他机器人相撞就返回该机器人的编号
}
}
return 0;
}
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
/**************************/ //初始化
for(int i=0; i<105; i++)
{
r[i].x=r[i].y=0;
r[i].dir=0;
}
bool flag=false;//标志是否发生碰撞
int f=0;//标志碰撞类型:0是无碰撞,-1是撞墙,其余是与其他机器人相撞
int f_=0;//储存碰撞类型
int num_=0;//记录发生碰撞的当前机器人
/**************************/
scanf("%d%d",&a,&b);
scanf("%d%d",&n,&m);
for(int i=1; i<=n; i++)//输入机器人的位置和方向
{
scanf("%d%d",&r[i].x,&r[i].y);
getchar();
scanf("%c",&r[i].dir);
}
int num,repeat;
char act;
while(m--)//处理各项动作
{
scanf("%d",&num);
getchar();
scanf("%c",&act);
scanf("%d",&repeat);
if(flag==false)
{
if(act=='L')
{
repeat%=4;
for(int i=0; i<repeat; i++)
{
if(r[num].dir=='E')
r[num].dir='N';
else if(r[num].dir=='N')
r[num].dir='W';
else if(r[num].dir=='W')
r[num].dir='S';
else if(r[num].dir=='S')
r[num].dir='E';
}
}
else if(act=='R')
{
repeat%=4;
for(int i=0; i<repeat; i++)
{
if(r[num].dir=='E')
r[num].dir='S';
else if(r[num].dir=='S')
r[num].dir='W';
else if(r[num].dir=='W')
r[num].dir='N';
else if(r[num].dir=='N')
r[num].dir='E';
}
}
else if(act=='F')
{
for(int i=0; i<repeat; i++)
{
if(flag==false)
{
if(r[num].dir=='E')
{
r[num].x++;
f=judge(num,r[num].x,r[num].y);
if(f!=0)
{
flag=true;
f_=f;
num_=num;
}
}
else if(r[num].dir=='S')
{
r[num].y--;
f=judge(num,r[num].x,r[num].y);
if(f!=0)
{
flag=true;
f_=f;
num_=num;
}
}
else if(r[num].dir=='W')
{
r[num].x--;
f=judge(num,r[num].x,r[num].y);
if(f!=0)
{
flag=true;
f_=f;
num_=num;
}
}
else if(r[num].dir=='N')
{
r[num].y++;
f=judge(num,r[num].x,r[num].y);
if(f!=0)
{
flag=true;
f_=f;
num_=num;
}
}
}
}
}
}
}
switch(f_)
{
case 0:
printf("OK\n");
break;
case -1:
printf("Robot %d crashes into the wall\n",num_);
break;
default:
printf("Robot %d crashes into robot %d\n",num_,f_);
}
}
}