Contest100000599 - 《算法笔记》6.4小节——C++标准模板库(STL)介绍->map的常见用法详解之问题 A: Speech Patterns (25)

问题 A: Speech Patterns (25)

时间限制: 1 Sec  内存限制: 32 MB

题目描述

People often have a preference among synonyms of the same word. For example, some may prefer "the police", while others may prefer "the cops". Analyzing such patterns can help to narrow down a speaker's identity, which is useful when validating, for example, whether it's still the same person behind an online avatar.

Now given a paragraph of text sampled from someone's speech, can you find the person's most commonly used word?

输入

Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return '\n'. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

输出

For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a "word" is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

Note that words are case insensitive.

样例输入

Can1: "Can a can can a can?  It can!"

样例输出

can 5

提示:

 会用到<ctype>库里的函数,想详细了解<ctype>库可点击链接:<ctype>常用的函数

此题考查字符串处理,遍历字符串,提取单词,当遇到空格或者非数字字母的字符时,即形成了一个符合要求的单词,我前天下午在学校自己的OJ上刚练习过类似的题目。

参考代码:

#include<iostream>
#include<string>
#include<cctype>
#include<map>

using namespace std;

int main()
{
    int i, j, Max=0;
    string s,t;
    map<string,int> M;
    getline(cin,s); 
    for(i=0;i<s.length();i++)
    {
        if(isalnum(s[i]))
        {
            s[i]=tolower(s[i]);
            t+=s[i];
        }
        if(!isalnum(s[i])||i==s.length()-1)
        {
            if(t.length()!=0)
            {
                M[t]++;
                t.clear();
            }
        }
    }
    map<string,int>::iterator it;
    for(it=M.begin();it!=M.end();it++)
    {
       if(it->second>Max)
        {
            Max=it->second;
            t=it->first;
      }
    }
    cout<<t<<" "<<Max<<endl;
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值