Power of Cryptography POJ-2109 解题报告

题目:POJ-2109

http://poj.org/problem?id=2109

Power of Cryptography
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 27286 Accepted: 13656

Description

Current work in cryptography involves (among other things) large prime numbers and computing powers of numbers among these primes. Work in this area has resulted in the practical use of results from number theory and other branches of mathematics once considered to be only of theoretical interest. 
This problem involves the efficient computation of integer roots of numbers. 
Given an integer n>=1 and an integer p>= 1 you have to write a program that determines the n th positive root of p. In this problem, given such integers n and p, p will always be of the form k to the n th. power, for an integer k (this integer is what your program must find).

Input

The input consists of a sequence of integer pairs n and p with each integer on a line by itself. For all such pairs 1<=n<= 200, 1<=p<10 101 and there exists an integer k, 1<=k<=10 9 such that k n = p.

Output

For each integer pair n and p the value k should be printed, i.e., the number k such that k n =p.

Sample Input

2 16
3 27
7 4357186184021382204544

Sample Output

4
3
1234

Source


解题思路:

神题神数据,直接用pow,或者取log就可以AC

样例的数据很大,但是该题中精度不会影响结果


pow的代码

#include <iostream> 
#include <cstdio>
#include <math.h>
using namespace std;

int main()
{
	double n,p;
	while (cin>>n>>p) {
		cout<<pow(p,1/n)<<endl;
	}
	return 0;
}

log的代码

#include<iostream>  
#include<cmath>  
#include<iomanip>  
using namespace std;  
int main()  
{  
    double n,p;  
    while(cin>>n>>p)  
    {  
        double c=exp(log(p)/n);  
        cout<<setiosflags(ios::fixed)<<setprecision(0)<<c<<endl;  
  
    }  
    return 0;  
} 

至于真正的“精准”的方法是用大数乘法以及二分法查找

样例中 

7 4357186184021382204544

结果是1234,就是说1234^7=4357186184021382204544

那么如何确定得到1234呢

先通过4357186184021382204544为22位数,然后22/7向上取整的到4

也就是说结果是在1000~9999之间的

然后通过二分计算就好了

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值