HDU1247——Hat’s Words(map黑科技,字符串)

Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Description
A hat’s word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.
You are to find all the hat’s words in a dictionary.

Input
Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 50,000 words.
Only one case.

Output
Your output should contain all the hat’s words, one per line, in alphabetical order.

Sample Input
a
ahat
hat
hatword
hziee
word

Sample Output
ahat
hatword

题意:找到所有可以由其它单词组合起来的单词。
到网上看到的map使用黑科技。

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <vector>
#include <cmath>
#include <queue>
#include <string>
#include <map>
#include <iostream>
using namespace std;

#define INF 1e9+7
#define MAXN 50010

map <string, int> a;

string str[MAXN];

int main() {
    int n=0;
    while(cin>>str[n])
    {
        a[str[n]]=1;
        n++;
    }
    for(int i = 0; i <= n; i++) {
        int e = (int)str[i].size()-1;
        for(int j = 1; j < e; j++) {
            //这是string的初始化,直接把str[i]分成两个部分,再做lgn的查询
            string s1(str[i], 0, j);
            string s2(str[i], j);
            if(a[s1] == 1 && a[s2] == 1) {
                cout << str[i] << endl;
                break;
            }
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值