关于集合整数表示的一些技巧以及状态压缩dp入门(POJ3254)

当元素比较少的时候,并且和集合状态有关的问题是,就可以考虑用一个二进制的整数来表示集合。

整数的每一位上,若为0则表示对应的元素不选取,若为1则表示对应的元素选取。以此为基础可以进行一些简单的集合运算。

空集:0     

只含有第i个元素的集合:1<<i      

含有从0开始的n个元素的集合:  1<<n-1    

判断第i个元素是否属于集合S:if(S>>i&1)

向集合中加入第i个元素:S|(1<<i)

向集合中删去第i个元素:S&~(1<<i)

判断集合T是否为S的子集:if((S|T)==S)


要枚举一个元素为0到n-1的集合的子集,直接从0枚举到1<<n-1

要枚举其中数量为k的子集:

<span style="font-size:14px;">int comb = (1<<k)-1;
while(comb<1<<n)
{
    int x=comb&-comb,y=comb+x;
    comb=((comb&-y)/x>>1)|1;
}</span>


有了以上这些基本知识,可以开始开心地学习状态压缩dp了。

状态压缩dp和普通dp不同的也就是每一个状态都和集合相关。状态的转移可以运用到集合运算知识。


我们来看一道入门题:

Corn Fields
Time Limit: 2000MS
Memory Limit: 65536K
Total Submissions: 12819
Accepted: 6719

Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers: M and N 
Lines 2..M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint

Number the squares as follows:
1 2 3
  4  

There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.


题意:农夫有一个草地,对应位置上为1代表可以放牛,为0代表不能放牛,询问放牛方案数。

思路:典型的和集合有关的题目。能影响到某行状态的,只有草地本身的要求和上一行的状态。每一行的方案数也就是上一行所有不冲突的状态的方案数之和。其它的也就是集合运算的问题了。具体的可以看代码。


#include<cstdio>
#include<cstring>
#include <string>
#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
#define MAXN 15
#define MODE 1000000000

int dp[MAXN][1<<MAXN];
int s[MAXN];

bool checkA(int S){
    return !(S&(S>>1));
}

bool checkB(int a,int b){
    return !(a&b);
}

int main()
{
    int n,m;
    memset(dp,0,sizeof(dp));
    scanf("%d%d",&n,&m);
    for(int i=0;i<n;i++){
        for(int j=0;j<m;j++){
            int x;
            scanf("%d",&x);
            if(x)
                s[i]=s[i]|(1<<j);//把第j位变成1,
        }
    }
    for(int i=0;i<(1<<m);i++){//求出第一行的合法数量
        if((s[0]|i)==s[0]&&checkA(i))
            dp[0][i]=1;
    }

    for(int i=1;i<n;i++){
        for(int j=0;j<(1<<m);j++)//枚举每一行的状态数
        {
            if(((s[i]|j)==s[i])&&checkA(j)){
                for(int k=0;k<(1<<m);k++){//枚举上一行的状态
                    if(checkB(j,k))
                        dp[i][j]=(dp[i][j]+dp[i-1][k])%MODE;
                }
            }
        }
    }
    long long ans=0;
    for(int j=0;j<(1<<m);j++){
        ans=(ans+dp[n-1][j])%MODE;
    }
    printf("%I64d\n",ans);
}








  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值