博弈论专题——推理与动态规划相关博弈之POJ2348

Euclid's Game
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8827 Accepted: 3605

Description

Two players, Stan and Ollie, play, starting with two natural numbers. Stan, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then Ollie, the second player, does the same with the two resulting numbers, then Stan, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with (25,7): 
         25 7

         11 7

          4 7

          4 3

          1 3

          1 0

an Stan wins.

Input

The input consists of a number of lines. Each line contains two positive integers giving the starting two numbers of the game. Stan always starts.

Output

For each line of input, output one line saying either Stan wins or Ollie wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed.

Sample Input

34 12
15 24
0 0

Sample Output

Stan wins
Ollie wins


给两个整数a和b,两个人先后用较大的数减去较小数的整数倍,并且保证相减后为非负数。先把一个数变为0的人获胜。

很显然,当大数是小数的整数倍时为必胜态。

从这道题学会一个叫做自由度的东西,感觉能够为博弈推理提供思路。

博弈基本就是一个推理必胜态和必败态的过程。自由度越低越好推理。

不妨假设b为两个数中的较大数。

如果b-a<a

那么只能选择用b去减a,如果后继态是必胜态,那么该状态是必败态,否则就是必胜态。

如果b-a>a呢?

我们怎么能够转移到自由度较低的情况。

假设x是是的b-x*a<a的整数。

那么我们用b减去(x-1)*a。这个就变成了第一种情况,如果第一种情况是必败态,那么此时就是必胜态。

如果减去(x-1)*a是必胜态呢?那么b-a*x是不是就变成了必败态?(有点绕,仔细想想),所以当前状态还是必胜态。

所以就是比谁先达到自由度高的情况即可。

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <math.h>
#include <stdlib.h>
using namespace std;


int a,b;
void solve(){
    bool f=true;
    for(;;){
        if(a>b)
            swap(a,b);
        if(b%a==0)
            break;
        if(b-a>a)
            break;
        b-=a;
        f=!f;
    }
    if(f)
        puts("Stan wins");
    else
        puts("Ollie wins");
}

int main(){
    while(scanf("%d%d",&a,&b)){
        if(a==0&&b==0)
            break;
        solve();
    }
}













  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值