HDU5724(多校第一场)——Chess(sg函数,状态压缩)

Chess

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1838    Accepted Submission(s): 811


Problem Description
Alice and Bob are playing a special chess game on an n × 20 chessboard. There are several chesses on the chessboard. They can move one chess in one turn. If there are no other chesses on the right adjacent block of the moved chess, move the chess to its right adjacent block. Otherwise, skip over these chesses and move to the right adjacent block of them. Two chesses can’t be placed at one block and no chess can be placed out of the chessboard. When someone can’t move any chess during his/her turn, he/she will lose the game. Alice always take the first turn. Both Alice and Bob will play the game with the best strategy. Alice wants to know if she can win the game.
 

Input
Multiple test cases.

The first line contains an integer  T(T100) , indicates the number of test cases.

For each test case, the first line contains a single integer  n(n1000) , the number of lines of chessboard.

Then  n  lines, the first integer of ith line is  m(m20) , indicates the number of chesses on the ith line of the chessboard. Then m integers  pj(1pj20)  followed, the position of each chess.
 

Output
For each test case, output one line of “YES” if Alice can win the game, “NO” otherwise.
 

Sample Input
  
  
2 1 2 19 20 2 1 19 1 18
 

Sample Output
  
  
NO YES


一般用sg函数求解的问题,也就是多个游戏的复合问题。

我们发现每行只有20个格子,所以由状态压缩能很容易地求出一个状态的后继态。

而n行便相当于n个游戏复合,这也就转化成nim了。

预处理每个状态的sg值即可。


#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <cmath>
#include <cstdlib>
using namespace std;
const int MAXN =21;
const long long INF =1000000007 ;
const long long MOD =(1ll<<32);
const double EPS=1e-8;
const double pi = acos(-1);
int sg[1<<MAXN];
int dfs(int s){
    if(sg[s]!=-1)
        return sg[s];
    if(s==0)
        return sg[s]=0;
    int vis[MAXN];
    memset(vis,0,sizeof(vis));
    for(int i=0;i<20;i++){
        if(s&(1<<i)){
            int temp=s^(1<<i);
            for(int j=i-1;j>=0;j--){
                if(!(s&(1<<j))){
                    temp=temp|(1<<j);
                    vis[sg[temp]]=1;
                    break;
                }
            }
        }
    }
    int ans=0;
    while(vis[ans])
        ans++;
    return sg[s]=ans;
}

int main(){
    memset(sg,-1,sizeof(sg));
    for(int i=0;i<1<<20;i++){
        dfs(i);
    }
    int t;
    scanf("%d",&t);
    while(t--){
        int n;
        scanf("%d",&n);
        int res=0;
        while(n--){
            int ans=0;
            int num;
            scanf("%d",&num);
            while(num--){
                int x;
                scanf("%d",&x);
                ans|=(1<<(20-x));
            }
            res^=sg[ans];
        }
        if(res)
            printf("YES\n");
        else
            printf("NO\n");
    }
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值