HDU4791——Alice's Print Service(线段树)

46 篇文章 1 订阅
11 篇文章 0 订阅

Alice's Print Service

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2240    Accepted Submission(s): 589


Problem Description
Alice is providing print service, while the pricing doesn't seem to be reasonable, so people using her print service found some tricks to save money.
For example, the price when printing less than 100 pages is 20 cents per page, but when printing not less than 100 pages, you just need to pay only 10 cents per page. It's easy to figure out that if you want to print 99 pages, the best choice is to print an extra blank page so that the money you need to pay is 100 × 10 cents instead of 99 × 20 cents.
Now given the description of pricing strategy and some queries, your task is to figure out the best ways to complete those queries in order to save money.
 

Input
The first line contains an integer T (≈ 10) which is the number of test cases. Then T cases follow.
Each case contains 3 lines. The first line contains two integers n, m (0 < n, m ≤ 10 5 ). The second line contains 2n integers s 1, p 1 , s 2, p 2 , ..., s n, p n (0=s 1 < s 2 < ... < s n≤ 10 9 , 10 9 ≥ p 1 ≥ p 2 ≥ ... ≥ p n ≥ 0).. The price when printing no less than s i but less than s i+1 pages is p i cents per page (for i=1..n-1). The price when printing no less than s n pages is p n cents per page. The third line containing m integers q 1 .. q m (0 ≤ q i ≤ 10 9 ) are the queries.
 

Output
For each query q i, you should output the minimum amount of money (in cents) to pay if you want to print q i pages, one output in one line.
 

Sample Input
  
  
1 2 3 0 20 100 10 0 99 100
 

Sample Output
  
  
0 1000 1000
 

Source


题意:给你n-1个区间,每个区间有个价格,m个询问,查询打印这些纸张得最小价格。可以打印空白得纸张。

线段树水题,首先查询纸张属于得区间,那么最小值只有可能是,纸张乘以其本身纸张价格,或者之后得每个区间头乘以其区间价格。这样就是一个RMQ问题了。


#include <cmath>
#include <cstring>
#include <cstdio>
#include <vector>
#include <string>
#include <algorithm>
#include <string>
#include <map>
#include <queue>
#include <set>
#include <stack>
#include <ctime>
#include <cstdlib>
#include <iostream>
#define pi 3.1415926
#define mod 1000000007
#define MAXN 100010
#define INF 0x3f3f3f3f3f3f3fLL
using namespace std;
long long s[MAXN],p[MAXN];

#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
long long MIN[MAXN<<2];
void pushup(int rt){
    MIN[rt]=min(MIN[rt<<1],MIN[rt<<1|1]);
}
void build(int l,int r,int rt){
    if(l==r){
        MIN[rt]=INF;
        return;
    }
    int m=(l+r)>>1;
    build(lson);
    build(rson);
    pushup(rt);
}

void update(int p,long long x,int l,int r,int rt){
    if(l==r){
        MIN[rt]=x;
        return;
    }
    int m=(l+r)>>1;
    if(p<=m)
        update(p,x,lson);
    else
        update(p,x,rson);
    pushup(rt);
}

long long query(int L,int R,int l,int r,int rt){
    if(L<=l&&r<=R){
        return MIN[rt];
    }
    int m=(l+r)>>1;
    long long res=INF;
    if(L<=m){
        res=min(res,query(L,R,lson));
    }
    if(R>m){
        res=min(res,query(L,R,rson));
    }
    return res;
}



int main()
{
    int t,n,m;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&n,&m);
        build(1,n,1);
        for(int i=1;i<=n;i++){
            scanf("%lld%lld",s+i,p+i);
            long long temp=s[i]*p[i];
            update(i,temp,1,n,1);
        }
        while(m--){
            int  q;
            scanf("%d",&q);
            long long ans;
            if(q>=s[n])
                ans=q*p[n];
            else if(q==0)
                ans=0;
            else{
                int l=1,r=n;
                while(l<r)
                {
                    int m=(l+r+1)/2;
                    if(s[m]<=q){
                        l=m;
                    }
                    else
                        r=m-1;
                   // cout<<l<<" "<<r<<endl;
                }
                //cout<<l<<" "<<r<<endl;
                ans=min(q*p[l],query(l+1,n,1,n,1));
            }
            printf("%lld\n",ans);
        }
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值